22.10.2014, 11:15 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Poll
Have you installed Xorg 7.0 already?
yes
77%
 77%  [ 46 ]
no, not yet
22%
 22%  [ 13 ]
i will not use it
0%
 0%  [ 0 ]
Stimmen insgesamt : 59


Autor Nachricht
devil
Titel: Have you installed Xorg 7.0? what are the probs/solutions?  BeitragVerfasst am: 13.04.2006, 11:19 Uhr
Team Member
Team Member


Anmeldung: 06. Mai 2005
Beiträge: 3087
Wohnort: berlin
hi there,
talk about your experience with xorg 7.0 here, if you like.
maybe some problems/solutions fit together.

greetz
devil

_________________
<<We are Xorg - resistance is futile - you will be axximilated>>

Host/Kernel/OS "devilsbox" running[2.6.19-rc1-git5-kanotix-1KANOTIX-2006-01-RC4 ]
CPU Info AMD Athlon 64 3000+ clocked at [ 803.744 MHz ]
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
homer911
Titel: RE: Have you installed Xorg 7.0? what are the probs/solution  BeitragVerfasst am: 13.04.2006, 11:37 Uhr



Anmeldung: 21. Jun 2005
Beiträge: 144
Wohnort: UK
3 Problems.

1. Display not working with KDE - Solved by following the advice on IRC and downloading fix-xorg7.sh

2. install-nvidia-debian.sh gives me an error about x-modules-path (logged on IRC - (bart), will recreate later today as I got over the problem by setting the driver to "nv" in the /etc/x11/xorg.conf file

3. bootup is considerably slower - but then I probably need to upgrade my hw Smilie
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
devil
Titel: RE: Have you installed Xorg 7.0? what are the probs/solution  BeitragVerfasst am: 13.04.2006, 11:45 Uhr
Team Member
Team Member


Anmeldung: 06. Mai 2005
Beiträge: 3087
Wohnort: berlin
homer,
did you run fix-fonts -e to fix slower boot?

greetz
devil

_________________
<<We are Xorg - resistance is futile - you will be axximilated>>

Host/Kernel/OS "devilsbox" running[2.6.19-rc1-git5-kanotix-1KANOTIX-2006-01-RC4 ]
CPU Info AMD Athlon 64 3000+ clocked at [ 803.744 MHz ]
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
wakarimasen
Titel: RE: Have you installed Xorg 7.0? what are the probs/solution  BeitragVerfasst am: 13.04.2006, 12:10 Uhr



Anmeldung: 09. Jun 2005
Beiträge: 120
Wohnort: Bromsgrove, UK
Hiding, until it's safe to come out and install...... Winken

_________________
tap tap tap....
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
drb
Titel:   BeitragVerfasst am: 13.04.2006, 12:57 Uhr



Anmeldung: 03. Jul 2004
Beiträge: 525

Asus a7n266 (nvidia 1)
XP1900
Matrox 550
1GB ram

dist-upgraded to xorg7 without any problems. Ran the fix-xorg7.sh script following the upgrade.

drb

_________________
Kernel 2.6.21-slh-up-7
_____________________
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
homer911
Titel:   BeitragVerfasst am: 13.04.2006, 13:03 Uhr



Anmeldung: 21. Jun 2005
Beiträge: 144
Wohnort: UK
Hi Devil,


Just did, and it helped. The bootup time is back to normal. (Especially from the KDM Login).

On the NVidia script, I should have said I'm using the 7174 module, (older card) not the 8178 one that comes with CeBIT 2006.

The error message is:
----------------------------------------------------------------------------------------------------------------------
patching file /usr/src/nv/nv.c
Hunk #2 succeeded at line 1034 (offset 6 lines)
./nvidia-installer: unrecognised option '--x-module-path=/usr/lib/xorg/modules'

Invalid commandline, please run './nvidia-installer --help' for usage information
----------------------------------------------------------------------------------------------------------------------------------------------


Cheers

Homer
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
stryder
Titel:   BeitragVerfasst am: 13.04.2006, 14:22 Uhr



Anmeldung: 26. Jun 2005
Beiträge: 389

Dist-upgraded yesterday... Results I posted here:

http://kanotix.com/PNphpBB2-viewtopic-t-17128.html

Just ran another dist-upgrade today (some other xorg file - common, I think) got installed) and also upgraded kernel to latest for good measure and:

1. Problem with firefox fixed (and gtk2 I guess)
2. Speed from nvidia screen to login screen, better. Screen refreshes, better.
3. Kano's script dumped a standard xorg.conf after kernel upgrade and nvidia install which stalled my mouse. I replaced xorg.conf with my original one and it's OK after init 3 and init 5.
4. For some reason firefox fonts in gnews got crappy - wonder why? Have always been OK. Anyway, apt-get install msttcorefonts and fix-fonts worked.

Like before, running fluxbox...
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
wakarimasen
Titel: Re: RE: Have you installed Xorg 7.0? what are the probs/solu  BeitragVerfasst am: 13.04.2006, 16:20 Uhr



Anmeldung: 09. Jun 2005
Beiträge: 120
Wohnort: Bromsgrove, UK
homer911 hat folgendes geschrieben::
3 Problems.

1. Display not working with KDE - Solved by following the advice on IRC and downloading fix-xorg7.sh


How did you do this - I have come out of hiding, and am now stuck at the X-screen Verlegen

_________________
tap tap tap....
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
neal
Titel: RE: Re: RE: Have you installed Xorg 7.0? what are the probs/  BeitragVerfasst am: 13.04.2006, 16:34 Uhr



Anmeldung: 21. Feb 2006
Beiträge: 8
Wohnort: Oregon City, OR, USA
Dist-upgraded yesterday following Neuer User's instructions - absolutely no problems getting
Xorg7. Thanks, Neuer User, Kano, etc.
One small change: glxgears run in konsole no longer reported frames/sec.

Dist-upgrade today broke something with nvidia driver - attempting to run glxgears or
any of the OpenGL screensavers crashed my KDE session and sent me back to the login
screen. Rerunning the install-nvidia-debian script fixed the problem.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Tami
Titel: Re: RE: Have you installed Xorg 7.0? what are the probs/solu  BeitragVerfasst am: 13.04.2006, 16:42 Uhr



Anmeldung: 30. Mar 2006
Beiträge: 10

wakarimasen hat folgendes geschrieben::
homer911 hat folgendes geschrieben::
3 Problems.

1. Display not working with KDE - Solved by following the advice on IRC and downloading fix-xorg7.sh


How did you do this - I have come out of hiding, and am now stuck at the X-screen Verlegen


do this:

Zitat:
Neuer_User wrote:
wget http://kanotix.com/files/fix-xorg7.sh , update-scripts-kanotix.sh , apt-get update ; apt-get dist-upgrade [on init 3], then run 'sh fix-xorg7.sh' run nvidia or ati script


(simply type it as su => <enter> instead of (,) )
Thanx to Neuer User advice and Kano's scripts I had no problems after today's distro upgrade Smilie
Thanks to all of you Überrascht)

_________________
http://tamihania.googlepages.com/home


Zuletzt bearbeitet von Tami am 13.04.2006, 16:44 Uhr, insgesamt ein Mal bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Neuer_User
Titel: Re: RE: Re: RE: Have you installed Xorg 7.0? what are the pr  BeitragVerfasst am: 13.04.2006, 16:43 Uhr



Anmeldung: 21. Nov 2004
Beiträge: 1018

neal hat folgendes geschrieben::
One small change: glxgears run in konsole no longer reported frames/sec.

glxgears --iacknowledgethatthistoolisnotabenchmark

(hope I did not misspell it Mit den Augen rollen )
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
homer911
Titel: RE: Re: RE: Have you installed Xorg 7.0? what are the probs/  BeitragVerfasst am: 13.04.2006, 16:46 Uhr



Anmeldung: 21. Jun 2005
Beiträge: 144
Wohnort: UK
OK,
-------------------------
Quick recap - wget http://kanotix.com/files fix-xorg7.sh (chmod a+x fix-xorg7.sh to make it usable)

ctrl+Alt+F1
init 3

apt-get update
Run fix-xorg7.sh (or ./fix-xorg7.sh)
apt-get dist-upgrade
install-nvidia-debian.sh (or whatever you use)

----------------

devil28's fix-fonts -e, improved the bootup time




I had to edit /etc/x11/xorg.conf to change the driver to"nv" on one pc and "mga" on another (Using pretty
old hw)

For the w/e I will need to try it out on mien kinder laptops Smilie
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
makke
Titel:   BeitragVerfasst am: 13.04.2006, 16:52 Uhr
Team Member
Team Member


Anmeldung: 02. Jan 2005
Beiträge: 905
Wohnort: Hagen
glxgears -iacknowledgethatthistoolisnotabenchmark
or much easier:
glxgears -printfps
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
jackiebrown
Titel: RE: Re: RE: Have you installed Xorg 7.0? what are the probs/  BeitragVerfasst am: 13.04.2006, 16:54 Uhr



Anmeldung: 13. Mai 2005
Beiträge: 732
Wohnort: Texas
I have X but there are a couple of problems. I am using the 64 bit version with the updated source list but

startx is and unrecognized command and kdesu and sux do not work for giving access to x programs.
kedsu gives me WARNING: No X authentication info set for display :0.0
sux gives me /usr/bin/sux: line 213: xauth: command not found

I think this might be related to the fact that xbase-clients is still at 6.9 and has no new version avaible.

_________________
Always acknowledge a fault. This will throw those in authority off their guard and give you an opportunity to commit more.
Mark Twain
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: RE: Re: RE: Have you installed Xorg 7.0? what are the probs/  BeitragVerfasst am: 13.04.2006, 17:22 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16275

7174 is pretty old. As nVidia does not provide a newer legacy driver blame Nvidia or go shopping Winken
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
homer911
Titel: RE: Re: RE: Have you installed Xorg 7.0? what are the probs/  BeitragVerfasst am: 13.04.2006, 17:33 Uhr



Anmeldung: 21. Jun 2005
Beiträge: 144
Wohnort: UK
Hey,

I'm suprised the BOX still works, never mind the card.

Still. now I think I have used up all the excuses NOT to go shopping Smilie

I would like to try a home build - any ideas as to motherboards and such like ?

Thanks for a great distro

Regards,

Homer
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
dpdt1
Titel: RE: Re: RE: Have you installed Xorg 7.0? what are the probs/  BeitragVerfasst am: 13.04.2006, 19:28 Uhr



Anmeldung: 05. Jan 2006
Beiträge: 42
Wohnort: Athens
64bit here, upgraded succesfully. sux doesn't work as said earlier plus i lost keyboard layout (greek in my case), and can't seem to recover it. xorg.conf seems exactly as it was before in that section but still i can't switch to greek no matter what..

_________________
Hey Bobby Marley
Sing Something Good To Me
This World Go Crazy
It's An Emergency
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
BklynBoy
Titel:   BeitragVerfasst am: 13.04.2006, 20:49 Uhr



Anmeldung: 17. Feb 2005
Beiträge: 237
Wohnort: Virginia, USA
drb hat folgendes geschrieben::

dist-upgraded to xorg7 without any problems. Ran the fix-xorg7.sh script following the upgrade.

drb


I have a problem. When I ran sh fix-xorg, I got: No such file or directory.

I had earlier run 'wget http://kanotix.com/files/fix-xorg7.sh'

Now I am stuck. Help.

UPDATE: I wget again, ran fix-xorg7, now all is well!


Zuletzt bearbeitet von BklynBoy am 13.04.2006, 20:59 Uhr, insgesamt ein Mal bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
dpdt1
Titel:   BeitragVerfasst am: 13.04.2006, 20:59 Uhr



Anmeldung: 05. Jan 2006
Beiträge: 42
Wohnort: Athens
did you move the script from where you downloaded it to /usr/local/bin ?
if not move it, make it executable and try again..

good luck..

_________________
Hey Bobby Marley
Sing Something Good To Me
This World Go Crazy
It's An Emergency
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
h2
Titel: RE: Re: RE: Have you installed Xorg 7.0? what are the probs/  BeitragVerfasst am: 13.04.2006, 21:12 Uhr



Anmeldung: 12. Mar 2005
Beiträge: 1005

I've created a full upgrade script, you can download it and get full instructions on the xorg7-h2 upgrade page as well. This script integrates the kano fix-xorg7 into it, but has more features.

The script, if you choose all the options, will upgrade a vanilla 2005-4 or cebit rc 3 install to the latest xorg 7. Or it will just install xorg 7, do a dist-upgrade, then let you reinstall your nvidia or radeon graphics drivers.

Rather than have two versions of these instructions, just go the link above to get the full upto date instructions.

Make sure to check the forums for any warnings before doing a dist-upgrade, these are not super safe right now.


Zuletzt bearbeitet von h2 am 16.04.2006, 08:35 Uhr, insgesamt 6 Male bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
homer911
Titel: RE: Re: RE: Have you installed Xorg 7.0? what are the probs/  BeitragVerfasst am: 13.04.2006, 21:19 Uhr



Anmeldung: 21. Jun 2005
Beiträge: 144
Wohnort: UK
IT works with CeBIT 2006 -so why not now ?

BTW: I just lost the last post I was trying to send. My side or Your side I can't tell
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
homer911
Titel: RE: Re: RE: Have you installed Xorg 7.0? what are the probs/  BeitragVerfasst am: 13.04.2006, 22:00 Uhr



Anmeldung: 21. Jun 2005
Beiträge: 144
Wohnort: UK
Ok -let's try again,

The script worked before xorg7 so it can only be xorg7 or fix-xorg7.sh

Sorry, IRC Is too busy for me to keep track (bart)
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
piper
Titel: RE: Re: RE: Have you installed Xorg 7.0? what are the probs/  BeitragVerfasst am: 13.04.2006, 23:22 Uhr
Team Member
Team Member


Anmeldung: 03. Mai 2005
Beiträge: 1544
Wohnort: out there somewhere
Well, before I did a d-u I went to #kanotix on IRC and asked if any problems with d-u,(I am gone away from home sun-tues at work and don't have access to a computer to check for myself) Kano answered within 2 seconds and told me exactly how to do it, had 1 slight problem (lost my icons control center) after which devil gave me the answer again within 2-3 seconds, all is well Winken Smilie The reply time for me if I have a problem on IRC is A-1 the best. I think so far the transition has been pretty smooth and painless.

====================================

27164 frames in 5.0 seconds = 5432.739 FPS
27153 frames in 5.0 seconds = 5430.520 FPS
27159 frames in 5.0 seconds = 5431.610 FPS
27169 frames in 5.0 seconds = 5433.678 FPS
27138 frames in 5.0 seconds = 5427.551 FPS

Host/Kernel/OS "KanotixBox" running Linux 2.6.16.5-kanotix-1 i686 [ KANOTIX 2006 CeBIT ]
CPU Info AMD Athlon XP 2400+ 256 KB cache clocked at [ 2000.448 MHz ]
Videocard ATI Radeon R350 [Radeon 9800 Pro] X.Org 7.0.0 [ 1024x768 @85hz ]
Network cards VIA VT6102 [Rhine-II], at port: e400
Processes 89 | Uptime 1:23 | Memory 418.719/756.121MB | HDD Maxtor 6Y160P0 Size 163GB (62%used) | GLX Renderer RADEON 9800 Pro Generic | GLX Version 2.0.5755 (8.24.Cool | Client Shell | Infobash v2.50rc10

_________________
h2's d-u script
h2's rdiff-backup script


Zuletzt bearbeitet von piper am 14.04.2006, 00:21 Uhr, insgesamt ein Mal bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
anticapitalista
Titel:   BeitragVerfasst am: 13.04.2006, 23:54 Uhr



Anmeldung: 23. Mai 2005
Beiträge: 174
Wohnort: Greece
Today I did a dist-upgrade following the instructions earlier in this thread (or somewhere) and no problems at all.

For what it's worth I followed the same procedure and used the kanotix script to upgrade my Mepis partitions too.

Many thanks for the great info.

_________________
Philosophers have interpreted the world in many ways; the point is to change it.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
mickhs
Titel: Xorg7 script  BeitragVerfasst am: 14.04.2006, 00:11 Uhr



Anmeldung: 27. Mar 2004
Beiträge: 31
Wohnort: Australia
Thank you very much, h2, for this script. Worked beautifully. Although I had my fingers crossed the whole time that it would work. Sehr glücklich

Very nice piece of work.

_________________
Cheers

mickhs
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.