10.12.2019, 22:53 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
jbs1136
Titel: Soundcard problems  BeitragVerfasst am: 23.07.2006, 04:50 Uhr



Anmeldung: 15. Jul 2006
Beiträge: 136
Wohnort: Spanaway, Wa
I have Kanotix64 installed and updated. My soundcard is a pci soundblaster live! 24. It is analog 7.1 and I have 5.1 speakers. I have no sound. I went to the manual on this site and found the configuration block. Opened console and did the few things that it said and I have great sound. Played lots of music from the xmmx. Closed it and later reopened it but had no sound. Had to repeat the steps again. I even did the alsactl store command but when I reboot I have no sound. I did KinfoCenter and the wrong card is showing, it shows the ALSA and not the ca0106 which is what it shows after I run alsaconfig in konsole. How do I store it where it will work when I reboot?

Thanks in advance,

John
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
mzilikazi
Titel: RE: Soundcard problems  BeitragVerfasst am: 23.07.2006, 05:20 Uhr
Team Member
Team Member


Anmeldung: 17. Dez 2003
Beiträge: 1109
Wohnort: Ganymede
Reboot the box and before configuring alsa do:
Code:
cat /proc/asound/cards

Let's see the results. It would be helpful to know if the card is at least detected and modules probed.
If the proper module(s) aren't even loaded you could add your required sound card module to /etc/modules. They'll get loaded on boot this way.

_________________
Ubuntu - An ancient African word for "Can't install Debian"
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
schnorrer
Titel: RE: Soundcard problems  BeitragVerfasst am: 23.07.2006, 13:14 Uhr



Anmeldung: 09. Jan 2006
Beiträge: 1720

Have you set you soundbalster to digital-out-only with windows? In this case boot win and set this soundcard option to No!
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
jbs1136
Titel: RE: Soundcard problems  BeitragVerfasst am: 24.07.2006, 08:53 Uhr



Anmeldung: 15. Jul 2006
Beiträge: 136
Wohnort: Spanaway, Wa
This is the result:
root@MainKanotix:~# cat /proc/asound/cards
0 [M5455 ]: ICH - ALi M5455
ALi M5455 with ALC658D at 0x0, irq 201

but it doesn't work. If I open root console and do alsaconf and go through the steps there and select soundblaster then it works. I just don't know how to store the choice so it will be correct when I reboot.

Soundblaster to digital - no, I did that once in windows and took me forever to find the problem of no sound. One of the first things I check.

Thanks guys,

John
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
schnorrer
Titel: RE: Soundcard problems  BeitragVerfasst am: 24.07.2006, 14:43 Uhr



Anmeldung: 09. Jan 2006
Beiträge: 1720

In this case, the ALI has it soundcard Activated and the SB-soundcard does not fit correctly in the PCI-Slot.

Same happend to me a few days ago. PCI-Soundcard doesn't fit and my DVB-Card has been partly found. Unable to watch tv but listen to the music.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
DeepDayze
Titel: RE: Soundcard problems  BeitragVerfasst am: 24.07.2006, 16:41 Uhr



Anmeldung: 08. Dez 2005
Beiträge: 299

try disabling onboard sound first in the BIOS and make sure the soundcard is firmly seated in the slot. Restart the system then try the alsaconf again. Hope that helps
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
jbs1136
Titel: RE: Soundcard problems  BeitragVerfasst am: 24.07.2006, 18:57 Uhr



Anmeldung: 15. Jul 2006
Beiträge: 136
Wohnort: Spanaway, Wa
Thanks guys, will try this and post back later. Damn, hate to take the covers off, just got them back on after being off for months.

John
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
jbs1136
Titel: RE: Soundcard problems  BeitragVerfasst am: 26.07.2006, 06:47 Uhr



Anmeldung: 15. Jul 2006
Beiträge: 136
Wohnort: Spanaway, Wa
Okay, took the cover off, removed the sound card and reinserted it. It did feel a little odd when I took it out. Crashed computer and reinstalled kanotix64. Started up, went to root console, alsaconf, went through the steps and set it up. Opened alsamixergui and adjusted sounds. Have opened and closed the program several times, rebooted at least twice and my music plays on!!! You guys are great, THANK YOU!! Had to shout that. Now if kaffeine would work. It crashes everytime I put music files in it. XMMS works great though.

When I run kaffeine and add music this is what happens:

"Short description
The application Kaffeine Player (kaffeine) crashed and caused the signal 11 (SIGSEGV)."

Any suggestions?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
schnorrer
Titel: RE: Soundcard problems  BeitragVerfasst am: 26.07.2006, 10:54 Uhr



Anmeldung: 09. Jan 2006
Beiträge: 1720

xine as the backend couldn't connect to the url from your music. It's not kaffeine primaries crash but as a result from xine.
Tip add all music-files to kaffeine than let kaffeine play.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
jbs1136
Titel: RE: Soundcard problems  BeitragVerfasst am: 27.07.2006, 03:28 Uhr



Anmeldung: 15. Jul 2006
Beiträge: 136
Wohnort: Spanaway, Wa
Thanks, I give that a try.

John
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.