30.10.2014, 17:27 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
Tejas
Titel: Kanotix Mute  BeitragVerfasst am: 18.09.2011, 15:03 Uhr



Anmeldung: 09. Mai 2011
Beiträge: 74

Kanotix is supposed to detect h/w like sound cards and appropriately configure it or driver if I'm not mistaken. Mint does this and I have no problem playing the Gnome Media Player. However I've failed to get any sound out of it here.

Step 1 See if your soundcard is detected
Code:
$ cat /proc/asound/cards
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe028000 irq 21
Presume sound card detected

Step 3 Play a file:
Code:
$ play /usr/share/sounds/KDE-Im-New-Mail.ogg
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
play FAIL formats: can't open output file `default': snd_pcm_open error: Device or resource busy
Step 4 Check all volumes are up and nothing is muted.
Code:
$ alsamixer
Not being a sound buff this is where I get lost Traurig

Only a Line Out to Speakers (No internal ones)

O/P of alsamixer attached:



alsamixer.png
 Beschreibung:
O/P of alsamixer
 Dateigröße:  89.39 KB
 Angeschaut:  8719 mal

alsamixer.png


 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
TheOne
Titel: Kanotix Mute  BeitragVerfasst am: 18.09.2011, 15:42 Uhr



Anmeldung: 15. Mar 2008
Beiträge: 610

Try to increase volume of PCM and Master channel.

_________________
Lenovo ThinkPad X220 | Core i7-2640M 16GB | Hellfire 3.6
FSC Tablet T4220 | Core2 Duo T7250 2GHz 3GB | Intel GMA X3100 | Hellfire 3.6
Clevo M570U | Core2 T7200 2GHz 2GB | Geforce Go 7950gtx | Hellfire 3.2
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
besenmuckel
Titel: Kanotix Mute  BeitragVerfasst am: 18.09.2011, 22:18 Uhr



Anmeldung: 28. Mar 2004
Beiträge: 970
Wohnort: Wolfenbuettel
sorry - no spreak english.
http://wiki.ubuntuusers.de/Soundkarten_ ... edirect=no
Zitat:
zless /usr/share/doc/alsa-base/driver/HD-Audio-Models.txt.gz

Die unterstützten Audiocontroller sind auch alternativ auf der Dokumentationsseite des Linuxkernels auf kernel.org {en} nachzulesen. Mit diesen möglichen Modellnamen beginnt nun die Arbeit. Man teilt ALSA mit, welcher Chip-Typ verwendet werden soll. Dazu muss die Datei /etc/modprobe.d/alsa-base.conf in einem Editor mit Root-Rechten bearbeitet werden [3]. An das Ende dieser Datei wird - um bei obigem Beispiel (für andere siehe Tabelle unten) zu bleiben - folgende Zeile eingefügt:

options snd-hda-intel model=3stack

Nach dem Ändern der Datei kann der Rechner neu gestartet werden. ALSA erfährt dann beim Starten, welcher HDA-Typ angesprochen wird. Alternativ dazu kann mittels rmmod das snd_hda_intel-Kernelmodul entfernt werden und mittels modprobe snd-hda-intel model=xxx neu geladen werden. Parallel dazu kann in einem zweiten Fenster mittels tail -f /var/log/syslog die Kernelausgabe via syslog verfolgt werden, ob das korrekte Modell für die Soundkarte geladen wurde.

Falls es nicht funktionieren sollte, muss man sämtliche verschiedenen Modelle durchprobieren, bis man das passende gefunden hat. Eventuell ist kein Sound - trotz des richtigen Modellnamens - hörbar. Deshalb sollte man mittels Alsamixer die Einstellungen der Regler und Schalter der Soundkarte überprüfen.

_________________
probieren geht über studieren
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
Kano
Titel: Kanotix Mute  BeitragVerfasst am: 18.09.2011, 22:34 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16275

Usally you need to increase front too.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Tejas
Titel: RE: Kanotix Mute  BeitragVerfasst am: 20.09.2011, 20:17 Uhr



Anmeldung: 09. Mai 2011
Beiträge: 74

besenmuckel hat folgendes geschrieben::
sorry - no spreak english.
No speaka da englisch? No problema Winken

http://wiki.ubuntuusers.de/Soundkarten_konfigurieren/HDA?redirect=no hat folgendes geschrieben::
Dazu muss die Datei /etc/modprobe.d/alsa-base.conf in einem Editor mit Root-Rechten bearbeitet werden [3]. An das Ende dieser Datei wird - um bei obigem Beispiel (für andere siehe Tabelle unten) zu bleiben - folgende Zeile eingefügt:

options snd-hda-intel model=3stack

Nach dem Ändern der Datei kann der Rechner neu gestartet werden. ALSA erfährt dann beim Starten, welcher HDA-Typ angesprochen wird.
Have followed this, but still problem persists. I tend to think it's something to do with thiis error:
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
play FAIL formats: can't open output file `default': snd_pcm_open error: Device or resource busy

Something seems to be either blocking access to or hogging the sound card. Kaffeine upon start-up comes up with the following:
Sorry - Kaffeine
Cannot create audio output

before crashing.

Thanks for the link and its related links which I am now having to wade through while waiting on more suggestions.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
TheOne
Titel: RE: Kanotix Mute  BeitragVerfasst am: 20.09.2011, 23:17 Uhr



Anmeldung: 15. Mar 2008
Beiträge: 610

If some application blocks your sound device, you can see that via
Code:
lsof | grep snd
If some apps that should be closed still block your device, try to kill them (killall or kill).

Regards TheOne

_________________
Lenovo ThinkPad X220 | Core i7-2640M 16GB | Hellfire 3.6
FSC Tablet T4220 | Core2 Duo T7250 2GHz 3GB | Intel GMA X3100 | Hellfire 3.6
Clevo M570U | Core2 T7200 2GHz 2GB | Geforce Go 7950gtx | Hellfire 3.2
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
besenmuckel
Titel: RE: Kanotix Mute  BeitragVerfasst am: 21.09.2011, 00:38 Uhr



Anmeldung: 28. Mar 2004
Beiträge: 970
Wohnort: Wolfenbuettel
Zitat:
lsof | grep snd

or
Code:
lsof | grep pcm

for lsof
Code:
apt-get install lsof

_________________
probieren geht über studieren
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
Tejas
Titel: RE: Kanotix Mute  BeitragVerfasst am: 22.09.2011, 19:45 Uhr



Anmeldung: 09. Mai 2011
Beiträge: 74

EPILOG -> Pfeil -> A Sound Mystery

To recap:

besenmuckel hat folgendes geschrieben::
for lsof
Code:
apt-get install lsof
Package already installed in both Mint and Kanotix distros.

TheOne hat folgendes geschrieben::
If some application blocks your sound device, you can see that via
Code:
lsof | grep snd
This produced a plethora of info, and I ended up not being able to see the wood for the trees and might have been in danger of killing an essential proces Traurig

besenmuckel hat folgendes geschrieben::
Code:
lsof | grep pcm
Thanx

Mint hat folgendes geschrieben::
mint@mint ~ $ lsof | grep pcm
pulseaudi 4642 mint mem CHR 116,3 13176 /dev/snd/pcmC0D0p
pulseaudi 4642 mint 36u CHR 116,3 0t0 13176 /dev/snd/pcmC0D0p
plugin-co 5013 mint mem REG 0,16 22076 19784 /usr/lib/alsa-lib/libasound_module_pcm_pulse.so


besenmuckel hat folgendes geschrieben::
http://wiki.ubuntuusers.de/Soundkarten_konfigurieren/HDA?redirect=no hat folgendes geschrieben::
Dazu muss die Datei /etc/modprobe.d/alsa-base.conf ... folgende Zeile eingefügt:

options snd-hda-intel model=3stack

Nach dem Ändern der Datei kann der Rechner neu gestartet werden. ALSA erfährt dann beim Starten, welcher HDA-Typ angesprochen wird.

After restarting the problem still persisted. Well since then there has been an intervening cold start.

On getting to desktop minimised all windows and ran
Code:
kanotix@Kanotix:~$ lsof | grep pcm
lsof: WARNING: can't stat() ext2 file system /isofrom
      Output information may be incomplete.
lsof: WARNING: can't stat() squashfs file system /filesystem.squashfs
      Output information may be incomplete.
lsof: WARNING: can't stat() ext2 file system /live-rw-backing
      Output information may be incomplete.

Possibly no one blocking sound access, so ran Kaffeine, which worked Ausrufezeichen
Following which ran
Code:
kanotix@Kanotix:~$ lsof | grep pcm
kaffeine- 3538    kanotix  mem       CHR      116,3             10697 /dev/snd/pcmC0D0p
kaffeine- 3538    kanotix   19u      CHR      116,3       0t0   10697 /dev/snd/pcmC0D0p

TheOne hat folgendes geschrieben::
Try to increase volume of PCM and Master channel.
Kano hat folgendes geschrieben::
Usally you need to increase front too.
With Kaffeine running, ran 'alsamixer' and was able to adjust contols and eliminate unnecessary ones -> -> Pfeil Pfeil Pfeil



Ran Flash Video in Iceweasel
Code:
kanotix@Kanotix:~$ lsof | grep pcm
plugin-co 3715    kanotix  mem       CHR      116,3             10697 /dev/snd/pcmC0D0p
plugin-co 3715    kanotix   22u      CHR      116,3       0t0   10697 /dev/snd/pcmC0D0p
Played a sound
Code:
kanotix@Kanotix:~$ play /usr/share/sounds/KDE-Im-New-Mail.ogg
/usr/share/sounds/KDE-Im-New-Mail.ogg:

 File Size: 23.4k     Bit Rate: 181k
  Encoding: Vorbis       
  Channels: 2 @ 16-bit   
Samplerate: 48000Hz     
Replaygain: off         
  Duration: 00:00:01.03 

In:100%  00:00:01.03 [00:00:00.00] Out:49.7k [      |      ]        Clip:0   
Done.
Ran Gnome Media Player followed by a Sound
Code:
kanotix@Kanotix:~$ lsof | grep pcm
mplayer   4712    kanotix  mem       CHR      116,3             10697 /dev/snd/pcmC0D0p
mplayer   4712    kanotix    7w      CHR      116,3       0t0   10697 /dev/snd/pcmC0D0p
kanotix@Kanotix:~$ play /usr/share/sounds/KDE-Im-New-Mail.ogg

/usr/share/sounds/KDE-Im-New-Mail.ogg:

 File Size: 23.4k     Bit Rate: 181k
  Encoding: Vorbis       
  Channels: 2 @ 16-bit   
Samplerate: 48000Hz     
Replaygain: off         
  Duration: 00:00:01.03 

In:100%  00:00:01.03 [00:00:00.00] Out:49.7k [      |      ]        Clip:0   
Done.
Had gnome audio o/p set to 'pulse' but there was no sound until reset to 'alsa'
Checked sound file device
Code:
kanotix@Kanotix:~$ lsof | grep pcm
plugin-co 4739    kanotix  mem       CHR      116,3             10697 /dev/snd/pcmC0D0p
plugin-co 4739    kanotix   20u      CHR      116,3       0t0   10697 /dev/snd/pcmC0D0p

Flash Plugin seems to always grab the sound device file, but this time appears to have relinquished it to the active process. It is this same plugin plugin-co which had the sound device file before, when nothing was happening. So it remains a puzzle as to why this plugin now seems to be behaving properly.Frage Frage

Attached file lists all processes on m/c., and maybe s.o. can spot one which could have been responsible for locking out processes from the sound device file.



ps-eU.gz
 Beschreibung:
Running Processes

Download
 Dateiname:  ps-eU.gz
 Dateigröße:  1.98 KB
 Heruntergeladen:  356 mal

 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.