23.10.2014, 17:56 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
totschka
Titel: Mit Kernel 3.2.0 Internet über WLAN langsam  BeitragVerfasst am: 11.01.2012, 20:10 Uhr



Anmeldung: 27. Jun 2007
Beiträge: 402

Mein Netbook Samsung N130:
Zitat:
Host/Kernel/OS "netbook" running Linux 3.0.16-030016-generic i686 [ Kanotix Hellfire 20110511-14:43 ]
CPU Info (1) Intel Atom N270 @ 512 KB cache flags ( sse sse2 nx pni ) clocked at [ 800.000 MHz ]
(2) Intel Atom N270 @ 512 KB cache flags( sse sse2 nx pni ) clocked at [ 800.000 MHz ]
Videocard Intel Mobile 945GME Express Integrated Graphics Controller X.Org 1.10.4 [ 1024x600 ]
Network cards Atheros AR9285 Wireless Network Adapter (PCI-Express)
Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller, at port: 2000
Processes 125 | Uptime 4min | Memory 196.1/2004.1MB | HDD ATA SAMSUNG HM160HI Size 160GB (26%used) | Client Shell | Infobash v2.67.2


Mit diesem Kernel ist die Geschwindigkeit der Datenübertragung zufriedenstellend.

Mit dem Kernel 3.2.0-030200-generic i686 sieht das anders aus. Internet ist echt lahm, obwohl der Networkmanager einen um ca. 10-15% höheren Pegel anzeigt.
Beim 38er Kernel gabs mit der ath9k mal kurz ein Problem, was mit dem Eintrag
Code:
options ath9k nohwcrypt=1
in /etc/modprobe.d/ath9k.conf behoben werden konnte.

Beim Kernel 3.2.0 zeigt sich keinerlei Unterschied, ob mit oder ohne Datei /etc/modprobe.d/ath9k.conf.

An den Verbindungseinstellungn habe ich nichts geändert, die Namensauflösung geht über 8.8.8.8 und 8.8.4.4.

ifconfig:
Code:
eth0      Link encap:Ethernet  Hardware Adresse 00:13:77:bd:aa:7b 
          UP BROADCAST MULTICAST  MTU:1500  Metrik:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:42

lo        Link encap:Lokale Schleife 
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:16436  Metrik:1
          RX packets:10 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0
          RX bytes:660 (660.0 B)  TX bytes:660 (660.0 B)

wlan0     Link encap:Ethernet  Hardware Adresse 0c:60:76:2b:f6:11 
          inet Adresse:192.168.0.106  Bcast:192.168.0.255  Maske:255.255.255.0
          inet6-Adresse: fe80::e60:76ff:fe2b:f611/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:204 errors:0 dropped:0 overruns:0 frame:0
          TX packets:207 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:170046 (166.0 KiB)  TX bytes:26189 (25.5 KiB)


iwconfig:
Code:
lo        no wireless extensions.

pan0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"WBR-6001" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:11:6B:2B:24:1C   
          Bit Rate=150 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=49/70  Signal level=-61 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:7  Invalid misc:29   Missed beacon:0

eth0      no wireless extensions.


Der Kernel 3.0.16 läuft, die Helligkeitsregelung macht damit keine Probleme mehr, beim Kernel 3.2.0 ist es aber eindeutig besser. Deshalb würde ich den gerne nutzen, was mir das langsame Internet übers WLAN ein wenig verleidet.
Gibt es da Abhilfe?

P.S.: Verwendete Bowser: Iceweasel 9.0.1, Chromium 6.0.472.63 - kein signifikanter Unterschied zwischen den Browsern.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
totschka
Titel:   BeitragVerfasst am: 15.01.2012, 13:39 Uhr



Anmeldung: 27. Jun 2007
Beiträge: 402

Mit dem Kernel 3.2.1 siehts noch schlechter aus. Quälend langsamer Seitenaufbau, sobald ich paar Meter weg bin vom Router.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Predpray
Titel:   BeitragVerfasst am: 01.03.2012, 15:51 Uhr



Anmeldung: 30. Apr 2010
Beiträge: 13

Hallo,

ich quäle mich auch einigermaßen mit dem WLAN Gedöns herum. Erfreulicherweise läuft mit Kanotix nun auch mein Fritz! WlanStick wieder. Ich habe übrigens eine 2.Fritzbox als Verstärker aufgestellt. Klappt sehr gut.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.