19.11.2017, 15:58 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
PitTux
22 Titel: kein X nach d-u für Df  BeitragVerfasst am: 15.10.2014, 19:09 Uhr



Anmeldung: 26. Aug 2004
Beiträge: 1181
Wohnort: Hessen/Kassel-Fuldatal
Nach dem letzten d-u, 14.10. startet kein x nach dem Neustart, sondern Login in der Konsole.
Da ich wieder in der Klinik bin, braucht mein Sohn eine Anleitung.

d-u hat er mit -f wiederholt, aber passiert ist nur der nochmale Ablauf. Der neue NVidea-Treiber wurde wohl mit dem Kernel nicht kompiliert.

dpkg --configure -a hat auch nichts gebracht.

Was sollte er in die Konsole eintippen? c+p ist ja nicht möglich oder muss er das was der Bot unter !nvdeb anzeigt abtippen?

Gruss
Peter

_________________
ich habe zwar keine Lösung, bewundere aber das Problem
Quad Intel Core i3-4350T - Linux 4.12.0-12-generic x86_64 [ Kanotix Steelfire-Testbuild KDE-Plasma 5 20170818-17:45 ]; Netrunner 17 (»Horizon«) [Stretch]; KaOS
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden MSN Messenger  
Antworten mit Zitat Nach oben
besenmuckel
Titel: kein X nach d-u für Df  BeitragVerfasst am: 15.10.2014, 20:38 Uhr



Anmeldung: 28. Mar 2004
Beiträge: 1035
Wohnort: Wolfenbuettel
du kannst alles in der konsole machen, wenn es dir nicht liegt dann.
um mit minimalen xserver zu arbeiten, kannst du die xorg.conf ändern.
Code:
root
passwort
mcedit /etc/X11/xorg.conf

ändere "nvidia" in "vesa"
mit F10 beenden - speichern auswählen.
Anmeldebildschirm(kde=kdm, lxde=lightdm) neustarten
Code:
/etc/init.d/kdm restart

um nvidia zu enfernen, siehe irc unter
!nvdebrm
wenn nvidia entfernt sollte nach den neustart als standard nouveau starten.
um nvidia zu installieren , siehe irc unter
!nvdeb
die befehle lassen sich dann z. b. mit der rechten maustaste - kopieren und in der konsole einfügen. beim abtippen von langen befehlen können schnell fehler enstehen.
solltest du ein älteres iso haben und bei nvidia installieren, die fehler haben
nvidia-glx : Hängt ab von: nvidia-driver soll aber nicht installiert werden
wie Wosa beschrieben hier hat.
http://kanotix.com/PNphpBB2-viewtopic-t-27620.html
dann ist es besser ein neues !Nightly zu installieren. aktuell ist kernel 3.17 und NVIDIA 340.46. wenn du es nicht möchtest dann melde dich nochmal.

_________________
probieren geht über studieren
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
PitTux
Titel: kein X nach d-u für Df  BeitragVerfasst am: 16.10.2014, 06:47 Uhr



Anmeldung: 26. Aug 2004
Beiträge: 1181
Wohnort: Hessen/Kassel-Fuldatal
Hallo besenmuckel,
danke für die Anleitung. Nun denn Alexux Mit den Augen rollen

Bei Spitfire gabs auch mit dem neuen Treiber das Problem, ließ sich aber durch ein nochmal durchgeführte d-u beheben.
Hat das Install-Script da ein Problem? Sollte doch nach einem Neustart immer funktionieren!

_________________
ich habe zwar keine Lösung, bewundere aber das Problem
Quad Intel Core i3-4350T - Linux 4.12.0-12-generic x86_64 [ Kanotix Steelfire-Testbuild KDE-Plasma 5 20170818-17:45 ]; Netrunner 17 (»Horizon«) [Stretch]; KaOS
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden MSN Messenger  
Antworten mit Zitat Nach oben
besenmuckel
Titel: kein X nach d-u für Df  BeitragVerfasst am: 16.10.2014, 10:42 Uhr



Anmeldung: 28. Mar 2004
Beiträge: 1035
Wohnort: Wolfenbuettel
Zitat:
Hat das Install-Script da ein Problem?

welches Install-Script?
nochmals zur anleitung. sollte das modul nvidia geladen sein oder nicht richtig funktionieren.
überprüfen kannste mit
Code:
lsmod | grep nvidia

dann vorher kdm stop, nvidia entladen, kdm start. unter lxde wäre es als standard ightdm.
Code:
/etc/init.d/kdm stop
rmmod nvidia
/etc/init.d/kdm start

_________________
probieren geht über studieren
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
Kano
Titel: kein X nach d-u für Df  BeitragVerfasst am: 18.10.2014, 12:54 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16582

Des Problem tritt bei Leuten auf, die ein Konsolenfenster wegklicken und damit ein dist-upgrade UNTERBRECHEN, wenn eine Meldung kommt, dass das falsche Kernelmodul geladen ist. Wenn man korrekt ENTER drückt, passiert überhaupt nix und nach dem nächsten Reboot ist alles perfekt eingerichtet. Macht man das nicht, dann ist die Nvidia Treiber installation unvollständig und führt zu dem Verhalten.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
PitTux
Titel: kein X nach d-u für Df  BeitragVerfasst am: 06.11.2014, 12:01 Uhr



Anmeldung: 26. Aug 2004
Beiträge: 1181
Wohnort: Hessen/Kassel-Fuldatal
Also Spitfire installieren.

Schade das es das Script zur zur Neuinstallation der Grafikreiber auf der Konsole nicht mehr funktionieren.
Wie war das noch? apt-get install nividia-debian.sh

Oder ist dieser Beitrag beser?
https://wiki.debianforum.de/Unfreie_Gra ... BCr_NVIDIA

_________________
ich habe zwar keine Lösung, bewundere aber das Problem
Quad Intel Core i3-4350T - Linux 4.12.0-12-generic x86_64 [ Kanotix Steelfire-Testbuild KDE-Plasma 5 20170818-17:45 ]; Netrunner 17 (»Horizon«) [Stretch]; KaOS
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden MSN Messenger  
Antworten mit Zitat Nach oben
Kano
Titel: kein X nach d-u für Df  BeitragVerfasst am: 06.11.2014, 12:03 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16582

Warum sollte man die Scripte noch brauchen, wenn der binary Grafiktreiber in den Special ISO images schon drin ist? Einfach mit gfxdetect booten... Der Grund, warum ich die Scripte nicht mehr update ist übrigens, dass die mit multiarch nicht so ideal sind. Nur für Optimus support hab ich mal nen puren Nvidia installer gebraucht, werd ich demnächst nochmal überprüfen, ob das noch nötig ist. Die xrandr Ausgabe war halt immer falsch mit der Debian Paketierung.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
PitTux
Titel: kein X nach d-u für Df  BeitragVerfasst am: 06.11.2014, 14:53 Uhr



Anmeldung: 26. Aug 2004
Beiträge: 1181
Wohnort: Hessen/Kassel-Fuldatal
" Einfach mit gfxdetect booten... "

Betrifft doch nur Live?

Oder Grub entsprechend beim booten editieren?

_________________
ich habe zwar keine Lösung, bewundere aber das Problem
Quad Intel Core i3-4350T - Linux 4.12.0-12-generic x86_64 [ Kanotix Steelfire-Testbuild KDE-Plasma 5 20170818-17:45 ]; Netrunner 17 (»Horizon«) [Stretch]; KaOS
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden MSN Messenger  
Antworten mit Zitat Nach oben
Kano
Titel: kein X nach d-u für Df  BeitragVerfasst am: 06.11.2014, 17:30 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16582

Bootet man es Live so, dann ist es auf HD install genauo. Man kann es nachträglich aber auch aktivieren.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
besenmuckel
Titel: kein X nach d-u für Df  BeitragVerfasst am: 06.11.2014, 21:15 Uhr



Anmeldung: 28. Mar 2004
Beiträge: 1035
Wohnort: Wolfenbuettel
falls du den treiber per install-script oder run-datei installiert hast, funktioniert !nvdebrm und !nvdeb nicht und du hast kein X nach d-u für Df .bei ausführen von !nvdeb bekommst du dann auch die fehlermeldung nvidia-glx : Hängt ab von: nvidia-driver soll aber nicht installiert werden. ist mir auch passiert hatte den treiber per run-datei installiert, weiss aber nicht mehr warum ich es so gemacht habe. das iso war noch nicht alt keine 2 monate. deinstallieren kann man dann mit sh NVIDIAxxxxxxxxxxxxxxx.run --uninstall. Habe inzwischen aber neu installiert.

_________________
probieren geht über studieren
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
PitTux
Titel: kein X nach d-u für Df  BeitragVerfasst am: 07.11.2014, 08:35 Uhr



Anmeldung: 26. Aug 2004
Beiträge: 1181
Wohnort: Hessen/Kassel-Fuldatal
Habe nicht per run-datei installiert, ist nach d-u passiert. KA warum Kernel und nv nicht zusammengekommen sind.

"Man kann es nachträglich aber auch aktivieren."

Wie, bitte Input.

Oder kann man den Installationsprozess nochmal in der Konsole starten?

_________________
ich habe zwar keine Lösung, bewundere aber das Problem
Quad Intel Core i3-4350T - Linux 4.12.0-12-generic x86_64 [ Kanotix Steelfire-Testbuild KDE-Plasma 5 20170818-17:45 ]; Netrunner 17 (»Horizon«) [Stretch]; KaOS
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden MSN Messenger  
Antworten mit Zitat Nach oben
Kano
Titel: kein X nach d-u für Df  BeitragVerfasst am: 08.11.2014, 12:10 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16582

Siehe

!nvdeb

Es war nur kurz so, dass ein paar Depends nicht erfüllbar waren, aber zuerst machst vielleicht lieber

!nvdebrm

und
Code:
apt-get autoremove --purge

und rebootest (reboot).
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
PitTux
Titel: kein X nach d-u für Df  BeitragVerfasst am: 08.11.2014, 14:45 Uhr



Anmeldung: 26. Aug 2004
Beiträge: 1181
Wohnort: Hessen/Kassel-Fuldatal
in v1 Mit den Augen rollen

naja mehr wie vertippen kann ich mich nicht...

oder Spitfire drüber...

_________________
ich habe zwar keine Lösung, bewundere aber das Problem
Quad Intel Core i3-4350T - Linux 4.12.0-12-generic x86_64 [ Kanotix Steelfire-Testbuild KDE-Plasma 5 20170818-17:45 ]; Netrunner 17 (»Horizon«) [Stretch]; KaOS
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden MSN Messenger  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.