06.12.2019, 04:19 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
voigf
Titel: update-grub mit Fehlermeldung  BeitragVerfasst am: 26.10.2019, 19:10 Uhr



Anmeldung: 21. Dez 2017
Beiträge: 78

Hallo an alle Wissenden,
ich versuche mit einer Kanotix Live-CD meinen Rechner wieder zum Laufen zu bringen.

mount /dev/sdb3 >sdb3:Kanotx-Linuxpartition
mount --bind /dev/ /mnt/dev
chroot /mnt
update-grub

Fehlermeldung:
Zitat:
root@Kanotix:/# update-grub
GRUB-Konfigurationsdatei wird erstellt …
/proc/devices: fopen failed: Datei oder Verzeichnis nicht gefunden
Unknown device "/dev/sdb3": No such device
Unknown device "/dev/sdb1": No such device
Unknown device "/dev/sdb1": No such device
Unknown device "/dev/sdb2": No such device
.
.

Mit 'blkid' werden mir alle Partitionen angezeigt.
Kennt jemand einen Lösungsweg? Habe ich eine veraltete Vorgehensweise gewählt??
Für jeden Tipp bin ich dankbar.
voigf
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
schwedenmann
Titel: update-grub mit Fehlermeldung  BeitragVerfasst am: 27.10.2019, 05:57 Uhr



Anmeldung: 22. Jun 2004
Beiträge: 458
Wohnort: Wegberg
Hallo

Du mußt

Zitat:

mount /dev/sdb3 >sdb3:Kanotx-Linuxpartition


Du mußt einen Mountpoint angeben Winken

also mout /dev/sdb3 /mnt

mfg
schwedenmann

_________________
Linux,DOS,Windows
The Good, the bad, the ugly
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
voigf
Titel: update-grub mit Fehlermeldung  BeitragVerfasst am: 27.10.2019, 17:57 Uhr



Anmeldung: 21. Dez 2017
Beiträge: 78

Hallo schwedenmann,
du hast so recht.
Dein Vorschlag war berücksichtigt, nur nicht von mir mitgeteilt!! Verlegen
So ein Schiet! (wie man in Norddeutschland sagt)

Ich habe aktuell mein gestriges Vorgehen nocheinmal ausgeführt. Gleiches Ergebnis.
Dabei fiel mir folgender Schlusshinweis in den Fehlermeldungen auf:
Zitat:
Unknown device "/dev/sdb3": No such device
Unknown device "/dev/sdb4": No such device
Unknown device "/dev/sdb3": No such device
/proc/devices: fopen failed: Datei oder Verzeichnis nicht gefunden
Unknown device "/dev/sdb3": No such device
grep: /proc/mounts: Datei oder Verzeichnis nicht gefunden
Cannot find list of partitions! (Try mounting /sys.)
erledigt
root@Kanotix:/#

Wo steckt nur die Datei 'mounts'?? Ich werde mal suchen. Aber wie geht es dann weiter??

Vielleicht gibt es ja doch noch eine Lösung??
Gruß und Dank, voigf
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
towo2099
Titel: update-grub mit Fehlermeldung  BeitragVerfasst am: 27.10.2019, 20:08 Uhr



Anmeldung: 23. Sep 2004
Beiträge: 599

Du sollets vielleicht nochmal lesen, wie man chroot benutzt!
Zitat:
mount --bind /dev/ /mnt/dev


Dieser bindmount alleine reicht nämlich nicht, was dir ja nun auch mehrfach per Fehelermeldung mitgeteilt wird!

_________________
Ich bin nicht die Signatur, ich Putz' hier nur Winken
Nach Diktat spazieren gegangen Auf den Arm nehmen
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
voigf
Titel:   BeitragVerfasst am: 27.10.2019, 23:41 Uhr



Anmeldung: 21. Dez 2017
Beiträge: 78

@towo2099
Danke für die Hile.
Werde mich schlaulesen.
Bin leider in der kommenden Woche aushäusig. Traurig
Werde die Zeit aber nutzen!
Bis dahin Gruß, voigf
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
voigf
Titel:   BeitragVerfasst am: 05.11.2019, 18:17 Uhr



Anmeldung: 21. Dez 2017
Beiträge: 78

Nach einer Woche (endlich) wieder bei den alten Problemen! Verlegen
Bekomme jetzt unmittelbar vor dem erwarteten Booten die Fehlermeldung:
Zitat:
error: unknown filesystem
Entering rescue mode...
grub rescue >

Zitat:
grub rescue > ls
(hd0) (hd0,msdos6) (hdo, msdos5) ... (hd1) (hd1,msdos4) (hd1,msdos3) ...


'blkid' über eine Kanotix-Live-Installation liefert von 2.HD keine identischen Einträge, verglichen mit Einträgen der 'fstab' des installierten OS Steelfire. 'blkid'-Einträge der 1.HD sind mit 'fstab' identisch.


Weiß jemand Rat, wie ich aus diesem Dilemma herauskomme??
Dank im Voraus!!!!!!!
voigf
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
thebluesman
Titel:   BeitragVerfasst am: 08.11.2019, 09:56 Uhr



Anmeldung: 06. Okt 2007
Beiträge: 377
Wohnort: Leipzig
hatte mal auch diese Fehlermeldung

http://kanotix.com/index.php?name=PNphp ... highlight=
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 12.11.2019, 19:00 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16691

Bei legacy Systemen:

https://kanotix.com/index.php?module=pn ... Reparieren

Bei UEFI zusätzlich vor grub-install noch ein:
Code:
mount /boot/efi
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
voigf
Titel:   BeitragVerfasst am: 14.11.2019, 17:42 Uhr



Anmeldung: 21. Dez 2017
Beiträge: 78

@thebluseman
Hatte ich schon mit Hilfe dieses Links versucht! Leider ohne Erfolg!
Danke für deinen Einsatz.
@Kano
Schade, dein Link '...Reparieren' kommt leider ein paar Tage zu spät. Bin mächtig unterwegs in letzter Zeit und habe es mit einer schnellen Lösung (Plattmachen) versucht. Das ging mächtig nach hinten los!! Bin jetzt dabei, das System ganz neu einzurichten. Das wir ein paar Tage (Wochen??) in Anspruch nehmen. Traurig
Dank dir auch für deinen Einsatz.

Bis zur nächsten Frage in hoffentlich (für mich) ruhigeren Zeiten.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.