02.09.2014, 06:15 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
Ashton
Titel: Controlling fan speed  BeitragVerfasst am: 25.05.2006, 19:18 Uhr



Anmeldung: 28. Sep 2005
Beiträge: 16
Wohnort: Michigan, USA
Hi all, I'm running Easter RC4 on my AMD Dual-core 4800 on an Asus A8N-E motherboard. The fan is a Thermaltake AMD K8 Venus 7+ Hi. KDE System Guard tells me that I'm running a straight 40 degrees C. This is well below operating guidelines. The fan is on all the time, 100% (again from System Guard). It's loud. It's right by my ear. I would like it to be quieter!

I've tried enabling 'Cool 'n Quiet' from the BIOS, but no change. I looked into lm-sensors, which seems daunting. Is there a package I could employ that would handle this problem fairly painlessly? Or am I missing something in the BIOS setup that would do this easily?

Thanks in advance for any pointers!
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
kstevek
Titel: RE: Controlling fan speed  BeitragVerfasst am: 25.05.2006, 20:15 Uhr



Anmeldung: 26. Jan 2006
Beiträge: 37

If you have lm-sensors installed you could try fancontrol which I think is part of the lm-sensors package.
type "fancontrol" in a console and read what it says fully coz if it works it will stop your fans briefly but they should start again straight away, dunno if it will work with your mobo but worth a try...
(google "fancontrol" for more info)

cheers kstevek

_________________
Skip built box, AMD Athlon XP1700,Jetway mobo (no sensors), geforce2 mx400, 512m ram, wireless.
running Kanotix Easter edition, xorg7, kernel 2.6.18.5-slh-up-1, beryl enhanced kde boing boing!
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Ashton
Titel:   BeitragVerfasst am: 25.05.2006, 22:15 Uhr



Anmeldung: 28. Sep 2005
Beiträge: 16
Wohnort: Michigan, USA
kstevek, thanks for the pointer - I've learned something, and it was very helpful... but it didn't work, at least not yet.

fancontrol requires running sensors-detect (a script from the lm-sensors package) to identify sensors. Then you need to modprobe the indicated drivers. Now, running sensors will print some interesting information about your system.

However, when I try to run fancontrol (or its configuration program pwmconfig) I get the message, 'There are no pwm-capable sensor modules installed'. Clearly I'm missing something. Any idea what it could be?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
datebro
Titel:   BeitragVerfasst am: 25.05.2006, 22:38 Uhr



Anmeldung: 10. Sep 2004
Beiträge: 413

The Fan is not controlled by powernow but by bios. There are two Points to activate. First, Cool & Quiet for controlling the cpu-frequency, you have obviously done. second is hidden in menu power, hardware-health or similar (its the tab where you can see the actual temperatures and frequencies), named Q-Fan-control, which must be activated too. try this and have fun

Greetings
Datebro
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Ashton
Titel:   BeitragVerfasst am: 25.05.2006, 23:14 Uhr



Anmeldung: 28. Sep 2005
Beiträge: 16
Wohnort: Michigan, USA
datebro, you are right - there was another BIOS setting. This let me set a maximum temperature. Things are eerily quiet in my office now! I will turn things off and turn on tomorrow to see if the temperature reading is accurate so I don't burn out my cpu tonight. Thanks for the help!
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Ashton
Titel:   BeitragVerfasst am: 26.05.2006, 19:05 Uhr



Anmeldung: 28. Sep 2005
Beiträge: 16
Wohnort: Michigan, USA
Ok, things 'seem' to be working well now. The fan speed is much lower.

However, I have a second question. When I run sensors, I get the following (snipped) output:
fan1: 4017 RPM (min = 811 RPM, div = Cool
fan2: 0 RPM (min = 0 RPM, div = 128)
fan3: 5869 RPM (min = 0 RPM, div = 2)
M/B Temp: +39 C (low = -1 C, high = -1 C) sensor = thermistor
CPU Temp: +36 C (low = -1 C, high = -1 C) sensor = thermistor
Temp3: +28 C (low = -1 C, high = -1 C) sensor = thermistor

Are the temperatures reported actually the temps inside my box?

Because when I run Gkrellm, I get the following temperature information:
CPU: 55 C
THRM: 40 C

These temps never seem to change, which makes me suspicious. My box doesn't seem too hot on the outside, so I'm inclined to trust the lower numbers. Why would there be a 15 degree difference?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
schnorrer
Titel:   BeitragVerfasst am: 26.05.2006, 22:34 Uhr



Anmeldung: 09. Jan 2006
Beiträge: 1721

The tempratures differs on the fly. let's asume only running lmsensors with a 15sec. wait between 2 measures and noting else is running. The temprature has not changed.

Running gkrelm seekperiod under 1sec. the temprature is right at 50°C and no worries with this.

Tempratures 58°C and above is too hot.

What you asked for, yes the temratures inside your box are ok. and are the average temps.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
h2
Titel:   BeitragVerfasst am: 06.06.2006, 21:00 Uhr



Anmeldung: 12. Mar 2005
Beiträge: 1005

ashton, you can install ksensors, gui front end for lm-sensors, then you can add the cpu / mobo temp to that, then check.

I think you have something wrong from what you said.

If you check with ksensors the temp reported while system is running at 1-2%, then start running a task that takes 100%, say ripping mp3s or something like that, and that lasts a while [rip a cd you have or something], and the temp does not move at all, something is not right.

Setting up sensors and fancontrol is a manual process, box has to be opened, you have to look at fans to see when they start and stop, if you didn't do that yet you haven't correctly installed it. It's a slight pain to do, but you only have to do it once.

As you noted, it's eery how quiet it is when you have a good cpu fan/heat sink, my hard drives are noisier usually than my boxes fans.

thermaltake copper heatsinks with slow speed fans are awesome, then with fancontrol you are literally talking whisper quiet. Has to be heard, or rather not heard, to be believed. Couple that with speed controlled 120 mm case fans and your system should run at ambient temperatures, system and cpu, with almost no sound.

sample sensors output:
Code:
fan1:        0 RPM  (min = 5487 RPM, div = 2)              ALARM
CPU Fan:  1854 RPM  (min = 4017 RPM, div = 8)              ALARM
fan3:     6308 RPM  (min = 4720 RPM, div = 2)
M/B Temp:    +36 C  (high =   +97 C, hyst =   +24 C)   sensor = thermistor
CPU Temp:  +35.5 C  (high =   +80 C, hyst =   +75 C)   sensor = thermistor
temp3:     +17.5 C  (high =   +80 C, hyst =   +75 C)   sensor = diode


I have my max cpu temp set too high, but other than that you can see that you haven't correctly set your cpu temp max yet.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.