12.12.2018, 03:27 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
herring
Titel: Sound works, but no MIDI  BeitragVerfasst am: 15.08.2006, 18:10 Uhr



Anmeldung: 01. Aug 2006
Beiträge: 5

I am running the 32-bit version of kanotix-2005-04. Sound works (KDE sounds, xmms, etc.) but I've installed a couple of games (Chromium, Quake 3) that have no sound. I went into the control center and there is no MIDI device. I click the "test sound" button and it works, "test midi" produces nothing.

The sound hardware is on the motherboard. It is identified in the BIOS as "AC97 audio" (there is no separate switch in the BIOS for a MIDI device). The mobo manual specifies "ALC850 CODEC (UAJ)".

Loaded modules and kernel are:
-----------------------------
Module Size Used by
nvidia 4540528 12
udf 81796 0
usb_storage 78784 0
video 14212 0
thermal 10888 0
fan 3460 0
container 3328 0
button 5008 0
battery 7684 0
ac 3460 0
fuse 30220 0
capability 3208 0
commoncap 5248 1 capability
powernow_k8 11016 0
freq_table 3716 1 powernow_k8
processor 18748 2 thermal,powernow_k8
8139too 23168 0
mii 4352 1 8139too
snd_intel8x0 28188 2
i2c_nforce2 5760 0
snd_ac97_codec 86048 1 snd_intel8x0
snd_ac97_bus 1920 1 snd_ac97_codec
snd_pcm_oss 47264 0
snd_mixer_oss 15488 1 snd_pcm_oss
snd_mpu401 5192 0
snd_mpu401_uart 5760 1 snd_mpu401
snd_rawmidi 20128 1 snd_mpu401_uart
snd_seq_device 6796 1 snd_rawmidi
snd_pcm 76808 4 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer 20740 2 snd_pcm
ehci_hcd 30856 0
snd 45156 12 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_mpu401,snd_mpu401_uart,snd_rawmidi,snd_seq_device,snd_pcm,snd_timer
8250_pnp 8320 0
soundcore 7392 1 snd
ohci_hcd 19204 0
8250 17828 1 8250_pnp
serial_core 17536 1 8250
shpchp 86884 0
pci_hotplug 24372 1 shpchp
analog 10400 0
gameport 11400 1 analog
pcspkr 3424 0
psmouse 33028 0
serio_raw 5508 0
amd64_agp 9672 1
agpgart 27592 2 nvidia,amd64_agp
snd_page_alloc 8072 2 snd_intel8x0,snd_pcm
usbcore 102912 4 usb_storage,ehci_hcd,ohci_hcd
parport_pc 35908 0
parport 30536 1 parport_pc
evdev 7296 0
adler@itchy:~$ uname -a
Linux itchy 2.6.14-kanotix-9 #1 PREEMPT Wed Dec 28 10:17:53 CET 2005 i686 GNU/Linux
--------------

I suspect the missing MIDI device is what's causing no sound in some games (but allowing sound in others, like frozen-bubble). What can I try to get this working?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
schnorrer
Titel: Sound works, but no MIDI  BeitragVerfasst am: 16.08.2006, 02:47 Uhr



Anmeldung: 09. Jan 2006
Beiträge: 1720

You have midi-Port enabeled for soundoutput. Then all midi-seq will go thru the gamport where midi connection resides.

You can hear Midi-Sonds with xmms configured midi-emulation on PCM
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
herring
Titel: Re: Sound works, but no MIDI  BeitragVerfasst am: 16.08.2006, 16:30 Uhr



Anmeldung: 01. Aug 2006
Beiträge: 5

schnorrer hat folgendes geschrieben::
You have midi-Port enabeled for soundoutput. Then all midi-seq will go thru the gamport where midi connection resides.

You can hear Midi-Sonds with xmms configured midi-emulation on PCM


Ok. What's the best way to redirect midi through the regular output (green audio jack)?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
mzilikazi
Titel:   BeitragVerfasst am: 16.08.2006, 20:17 Uhr
Team Member
Team Member


Anmeldung: 17. Dez 2003
Beiträge: 1109
Wohnort: Ganymede
I do not see the midi driver probed.
Code:
$ su
# modprobe snd_seq_midi

_________________
Ubuntu - An ancient African word for "Can't install Debian"
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
herring
Titel:   BeitragVerfasst am: 20.08.2006, 20:54 Uhr



Anmeldung: 01. Aug 2006
Beiträge: 5

mzilikazi hat folgendes geschrieben::
I do not see the midi driver probed.
Code:
$ su
# modprobe snd_seq_midi


OK. I did this. Now in the KDE Control Center, under Sound and Multimedia | Sound System | Hardware, "Select your MIDI Device" has two options.
*MPU-401 UART MIDI - ALSA Device
*Midi through port-0 - ALSA Device

However, neither one gets the "Test MIDI" button to produce any sound.

I found that the problem with Chromium was the KDE Sound System's "taking exclusive control over your sound hardware" so I cut auto-suspend to 10 seconds. But still no sound in Quake 3 Arena, even if I disable the Sound System altogether.

It seems the driver was a necessary but not sufficient step to get midi going (i added it to /etc/modules). Anything else I could try?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
mzilikazi
Titel:   BeitragVerfasst am: 21.08.2006, 00:37 Uhr
Team Member
Team Member


Anmeldung: 17. Dez 2003
Beiträge: 1109
Wohnort: Ganymede
I wouldn't know the first thing about Quake but I do know that you should disable ARTS entirely. Perhaps the Quake has a configuration for which sound device it will use? You should be using ALSA, not ARTS.

_________________
Ubuntu - An ancient African word for "Can't install Debian"
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
mzilikazi
Titel:   BeitragVerfasst am: 21.08.2006, 13:40 Uhr
Team Member
Team Member


Anmeldung: 17. Dez 2003
Beiträge: 1109
Wohnort: Ganymede
herring hat folgendes geschrieben::


It seems the driver was a necessary but not sufficient step to get midi going (i added it to /etc/modules). Anything else I could try?


Well if what you really want is to get midi working you'll need to install timidity.
Code:
apt-get install timidity

XMMS will play midi files with the proper plugin
Code:
apt-get install xmms-midi

_________________
Ubuntu - An ancient African word for "Can't install Debian"
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.