23.11.2014, 10:12 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
mr.mc.mauser
Titel: Agfa Snapscan 1212U  BeitragVerfasst am: 30.08.2006, 17:48 Uhr



Anmeldung: 17. Feb 2006
Beiträge: 136
Wohnort: Loreley
Hallo,

ich versuche vergeblich den Scanner Afga Snpascan 1212 U einzurichten aber es kommt immer folgende fehlermeldung:
snapscan:libusb:001:003 ungültiges Argument

Ich habe schon versucht das teil mittel dieser Anleitung zum Laufen zu bekommen:
http://www.netpeople.ch/piano/19.html

aber es klappt noch immer nicht !

Gruß
Robert

_________________
Schreibfehler sind beabsichtigt, Sie sollen der allgemeinen Erheiterung dienlich sein !!
 
 Benutzer-Profile anzeigen Private Nachricht senden ICQ-Nummer 
Antworten mit Zitat Nach oben
schmidtreiner
Titel: Agfa Snapscan 1212U  BeitragVerfasst am: 30.08.2006, 22:53 Uhr



Anmeldung: 08. Jun 2005
Beiträge: 104
Wohnort: Nördliche Lüneburger Heide
hmm,
hat das mit dem Firmware-Laden geklappt?
Habe selbst zwar keinen 1212 U sondern einen 1236 U der problemlos klappt (und auch keine Firmware laden muss) hatte aber vor ein paar Jahren so ein Gerät in ner Schule unter SuSE zum Laufen gebracht. Hierbei war auch das Laden der Firmware ausschlaggebend.
Wichtig ist auch dass der Scanner auch vom System gesehen wird, ich würde das erstmal mit System-tools checken (lsusb von der Konsole, usbview von ner X-Oberfläche, ev. auch das Infocenter unter KDE) anschliesend/alternativ solltest Du mal mit sane-find-scanner von ner Konsole ausprobieren ob der Scanner erkannt wird. Ich nehme an dass Du die /etc/sane.d/dll.conf gecheckt hast ob der snapscan Eintrag nicht auskommentiert ist.

Grüße

Reiner Schmidt


Zuletzt bearbeitet von schmidtreiner am 30.08.2006, 23:07 Uhr, insgesamt ein Mal bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
mr.mc.mauser
Titel: Agfa Snapscan 1212U  BeitragVerfasst am: 31.08.2006, 18:14 Uhr



Anmeldung: 17. Feb 2006
Beiträge: 136
Wohnort: Loreley
Hallo,

also der Scanner wird vom system erkannt !
allerdings ist da ein Fragezeichen !!
Code:
Robert@Notebook:~$ lsusb
Bus 003 Device 016: ID 062a:0000 Creative Labs
Bus 003 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 001 Device 002: ID 06bd:2061 AGFA-Gevaert NV SnapScan 1212U (?)
Bus 001 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Robert@Notebook:~$


in der dll.conf ist snapscan und agfa auskomentiert !

keine ahnung was ich noch tun soll
Gruß
Robert

_________________
Schreibfehler sind beabsichtigt, Sie sollen der allgemeinen Erheiterung dienlich sein !!
 
 Benutzer-Profile anzeigen Private Nachricht senden ICQ-Nummer 
Antworten mit Zitat Nach oben
schmidtreiner
Titel: Agfa Snapscan 1212U  BeitragVerfasst am: 01.09.2006, 12:54 Uhr



Anmeldung: 08. Jun 2005
Beiträge: 104
Wohnort: Nördliche Lüneburger Heide
Hallo,
ist das richtig dass die auskommentiert sind (ein # am Anfang der Zeile) ??
Wenn ja, dann weg mit dem # und nochmal probieren. Wie steht es mit dem Laden der Firmware ?

Grüße

Reiner Schmidt
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
mr.mc.mauser
Titel:   BeitragVerfasst am: 01.09.2006, 16:07 Uhr



Anmeldung: 17. Feb 2006
Beiträge: 136
Wohnort: Loreley
Hallo,

also meine /etc/sane.d/dll.conf sieht so aus:(auszug)
.
Code:
...
sharp
sm3600
sm3840
snapscan
sp15c
#st400
#st680
...


Die Firmware lade ich mit folgenden Script:
Code:
#!/bin/sh
perl /opt/SnapScanDrv/agfafirm /opt/SnapScanDrv/SnapScan-1212_2.bin

Natürlich habe ich unter /opt/SnapScanDRV die entsprechenden dateien abgelegt !
Dabei kommt keine Fehlermelung also gehe ich davon aus das es klappt !

Was kann sonst noch sein ?

Gruß
Robert

_________________
Schreibfehler sind beabsichtigt, Sie sollen der allgemeinen Erheiterung dienlich sein !!
 
 Benutzer-Profile anzeigen Private Nachricht senden ICQ-Nummer 
Antworten mit Zitat Nach oben
schmidtreiner
Titel:   BeitragVerfasst am: 02.09.2006, 12:12 Uhr



Anmeldung: 08. Jun 2005
Beiträge: 104
Wohnort: Nördliche Lüneburger Heide
Hallo,
viel mehr fällt mir im Moment nicht ein. die dll.conf Einträge sind soweit ok. was mich etwas verwirrt ist das Laden der Firmware (obwohl mein Wssen veraltet sein könnte).
In der snapscan.conf ist eigenlich eine Zeile zum Laden der Firmware vorgesehen "firmware ...". Das Laden über ein script sollte eigentlich nur benutzt werden wenn das erstere nicht funktioniert. Möglicherweise muss die Firmware jedesmal beim Scanaufruf geladen werden (?) Ebenfalls normalerweise auskommentierte Zeilen für den Fall dass der Scanner nicht automatisch gefunden wird (ob das in Zeiten von udev noch funktioniert weiss ich leider nicht). In deinem Falle wäre wohl mit /dev/usb/scanner0 bus=usb (bzw /dev/.static/dev/usb/scanner ...)zu experimentieren.
Die mit lsusb gefundene Adresse (0x6bd 0x2061) ist offensichtlich auch richtig da in der snapscan.conf diese als eine der zwei möglichen für den 1212U aufgeführt ist.
Noch eines fällt mir gerade auf => die in der Anleitung genannten Adressen (dev/usb/scanner0 etc.) haben sich mit udev wohl verändert. Bei mir liegt der Scanner jetzt bei /dev/.static/dev/scanner0). Die laut Anleitung eingerichteten devices (mknod /dev/usb/scanner0 c 180 4Cool laufen somit wahrscheinlich ins Leere Smilie
Check das mal bei Dir, wäre zumindest eine nachvollziehbare Fehlerursache, ebenfalls auch mal die Berechtigungen nachsehen (oder erstmal als root testen und dann später als user). Mit udev hat sich da wohl sehr vel geändert und ich habe da schon einige Überraschungen erlebt.

Grüße

Reiner Schmidt
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
mr.mc.mauser
Titel:   BeitragVerfasst am: 02.09.2006, 20:28 Uhr



Anmeldung: 17. Feb 2006
Beiträge: 136
Wohnort: Loreley
Hallo,

Danke Reiner !
Das mir dem Pfad zu /dev/.static/dev/scanner0 hat den erfolg gebracht

Super !!

Gruß
Robert

_________________
Schreibfehler sind beabsichtigt, Sie sollen der allgemeinen Erheiterung dienlich sein !!
 
 Benutzer-Profile anzeigen Private Nachricht senden ICQ-Nummer 
Antworten mit Zitat Nach oben
ockham23
Titel:   BeitragVerfasst am: 30.12.2013, 22:44 Uhr



Anmeldung: 25. Mar 2005
Beiträge: 2108

Habe mal meinen alten Snapscan 1212u aus dem Schrank hervorgekramt und siehe da, er läuft mit Dragonfire 64bit und XSane "out of the box" (bzw. "out of the closet"). Smilie

Allerdings benötigt man die Firmware-Datei "SnapScan1212 U_2.bin", die sich im Windows-Ordner "Programme -> Agfa -> Snapscan 2.0" befindet (32 KB, kopiert aus meiner WindowsXP-Partition).

Damit sane die Firmware auch finden und automatisch laden kann, muss man die Datei noch in "SnapScan1212U_2.bin" umbenennen (Entfernung des Leerzeichens) und dann den Dateipfad in /etc/sane.d/snapscan.conf eintragen. Ich habe die Firmware unter /usr/share/sane/snapscan/SnapScan1212U_2.bin abgespeichert. Auszug aus snapscan.conf:
Code:
#------------------------------ General -----------------------------------

# Change to the fully qualified filename of your firmware file, if
# firmware upload is needed by the scanner
firmware /usr/share/sane/snapscan/SnapScan1212U_2.bin

_________________
And I ain't got no worries 'cause I ain't in no hurry at all (Doobie Brothers, "Black Water").
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.