25.11.2014, 00:45 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
dennister
Titel: Hauppauge 250 WinTV--can't get it configured to get signal  BeitragVerfasst am: 04.11.2006, 04:19 Uhr



Anmeldung: 31. Okt 2006
Beiträge: 7
Wohnort: Toronto, Canada
I have removed the ati card, but the same problems persist with trying to get my hauppauge card configured: kdetv doesn't says no tuners exist, and xawtv still aborts without writing any configuration files with the message:

"the configuaration was aborted. Do you want to start xawtv anyway? (To deactivate the wrapper permanently create a ~/.xawtv or let this script finish normally)"

I have been able to find some diagnostics/other info from xawtv's website and the man pages...so here are some results of what's happening with the system:

This is xawtv-3.95, running on Linux/i686 (2.6.18-kanotix-1)
looking for available devices
port 274-274
type : Xvideo, image scaler
name : NV17 Video Texture

port 275-306
type : Xvideo, image scaler
name : NV05 Video Blitter

/dev/video0: OK [ -device /dev/video0 ]
type : v4l2
name : Hauppauge WinTV PVR-250
flags: capture tuner

root...#.....xawtv --device /dev/video0
This is xawtv-3.95, running on Linux/i686 (2.6.18-kanotix-1)
X Error of failed request: XF86DGANoDirectVideoMode
Major opcode of failed request: 137 (XFree86-DGA)
Minor opcode of failed request: 1 (XF86DGAGetVideoLL)
Serial number of failed request: 67
Current serial number in output stream: 67

Running 'xawtv -nodga' gave me a huge output, but it was still having trouble and trying to continue: quite a few 'no such device', then lots of devices found, but all were 'device or resource busy". Another minor worry was that it was still mentioning PAL repeatedly, with no mentions of NTSC or ivtv.

root@...#: scantv (apparently another way to write an xawtv or fbtv config file: the following were the choices I made of the 2 questions)
tv norm: NTSC-M (plain NTSC wasn't given as an option) frequency: us-cable
[global]
freqtab = us-cable

[defaults]
input = Television
norm = NTSC-M

ioctl: VIDIOC_S_STD(std=0xf [PAL_B,PAL_B1,PAL_G,PAL_H]): Device or resource busy
invalid value for input: television
valid choices for "input": "Tuner 1", "S-Video 1", "Composite 1", "S-Video 2", "Composite 2", "Composite 3"
ioctl: VIDIOC_S_STD(std=0x1000 [NTSC_M]): Device or resource busy
vbi: open failed [/dev/vbi]
open /dev/vbi: No such file or directory

That's all the info I can get...I have no idea where to go from here, except that I know this tuner is supposed to be using the ivtv drivers -- not the bttv. Pal is for Europe; Canada uses NTSC, and I've got a Scientific Atlanta Explorer setop box. Chain is wall--explorer--tuner--nvidia v card (yes, 3D opengl is configured)--monitor (coax cable from explorer to tuner; dvi-d cable from vcard to monitor).

No point in even trying to get the epg or lirc until card is configured and receiving some sort of signal from.

I've also been back at the ivtvdriver site, and there are 6 out of the 7 required modules in my system already (only tda9887 is missing). I tried to load them, and got that ivtv was in use, tveeprom was in use by ivtv, and the other five (wm8775, cx25840 tda9887 saa7115 saa7127) did not exist in /proc/modules. there was no output at all for the 'tuner' module, but it does exist on the system..

I'd really appreciate some help, and will paste this to the forum, but got no responses to my other post about possibly disabling the ati card, so that's why I removed it from the box.

Thanks in advance for any assistance, or places where you can point me to for more documentation. There has to be *somebody* who's gotten this very-common-card working under Kanotix. I'm really hating the idea of trying to install the ivtv drivers from source again (like I tried unsuccessfully to do with kubuntu) with tarballs, make, build-essential, etc.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: RE: Hauppauge 250 WinTV--can  BeitragVerfasst am: 04.11.2006, 10:54 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16296

Best use the Kanotix VDR menu and select the analog scan option. Then use VDR to watch tv.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
dennister
Titel: Re: RE: Hauppauge 250 WinTV--can  BeitragVerfasst am: 04.11.2006, 12:57 Uhr



Anmeldung: 31. Okt 2006
Beiträge: 7
Wohnort: Toronto, Canada
Kano hat folgendes geschrieben::
Best use the Kanotix VDR menu and select the analog scan option. Then use VDR to watch tv.


Tired that, and there's still a problem in setup.

<results snipped as nonexistent after a session close & restart
Update: It did finally scan for channels, but 'found 0 TV channels' see newest reply after devil's suggestion>

Xine also says 'No signal'. I have a nvidia 7800GT card configured correctly with the nvidia GLX renderer v7x. I've also tried to configure the vdr properly, and looked for help there, but alas, I am unilingual in English, so the portal isn't much good to me.

Should I be copying the ivtv modules that are not in /proc/...to that directory? They are elsewhere in the system, except for the tda one.


Zuletzt bearbeitet von dennister am 04.11.2006, 14:17 Uhr, insgesamt ein Mal bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
devil
Titel: Re: RE: Hauppauge 250 WinTV--can  BeitragVerfasst am: 04.11.2006, 13:13 Uhr
Team Member
Team Member


Anmeldung: 06. Mai 2005
Beiträge: 3087
Wohnort: berlin
`no signal` is good, it always appears at start of xine.
hit any number for a channel.
hit m to get a menu.

greetz
devil

_________________
<<We are Xorg - resistance is futile - you will be axximilated>>

Host/Kernel/OS "devilsbox" running[2.6.19-rc1-git5-kanotix-1KANOTIX-2006-01-RC4 ]
CPU Info AMD Athlon 64 3000+ clocked at [ 803.744 MHz ]
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
dennister
Titel: Kano's NTSC patch?  BeitragVerfasst am: 04.11.2006, 14:22 Uhr



Anmeldung: 31. Okt 2006
Beiträge: 7
Wohnort: Toronto, Canada
In xine, i hit the m as per devil's suggestion, but getting the menu is as far as I got. Kano: devil mentioned something about the problem perhaps being with NTSC, and you had made a patch for that?

I do have the cable setop box's channel set to 3, the standard here, from which all other channels can be accessed. With the other pvr apps I've tried in the past, i usually got at least got a signal for channel 3 when I scanned for channels (even without the epg installed properly, but not this time.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
gs
Titel: Kano  BeitragVerfasst am: 04.11.2006, 21:00 Uhr



Anmeldung: 06. Jan 2005
Beiträge: 632

with my Hauppauge 750 WINTV xawtv and kdetv are not working, but Tvtime does:
apt-get update
apt-get install tvtime
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
dennister
Titel: Re: Kano  BeitragVerfasst am: 04.11.2006, 23:59 Uhr



Anmeldung: 31. Okt 2006
Beiträge: 7
Wohnort: Toronto, Canada
gs hat folgendes geschrieben::
with my Hauppauge 750 WINTV xawtv and kdetv are not working, but Tvtime does:
apt-get update
apt-get install tvtime


ok, tried that, and at first tvtime said the resource was busy, so i stopped the vdr, and now tvtime says "invalid argument cannot open capture device /dev/video0". Of course, I haven't tried troubleshooting it beyond that --yet. will try said troubleshooting now. At least tvtime gave me the option of NTSC right away...scantv (part of xawtv) didn't; it just gve me NTSC-m, NTSC-k, and a differnt NTSC-x.

Another item of info that I think points to a deep problem: the web interface for vdradmin only gave me options for 2 svideos, 3 composite. That's it. I offer this info as possible clues.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
loyl1
Titel: RE: Re: Kano  BeitragVerfasst am: 05.11.2006, 04:41 Uhr



Anmeldung: 21. Dez 2005
Beiträge: 18

dennister,

I have a Hauppauge PVR350 working nicely. I can't remember all of the the steps, but make sure that you have handled the firmware:
http://ivtvdriver.org/index.php/Firmware

then look here:
http://ivtvdriver.org/index.php/Howto:Debian
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
piper
Titel: RE: Re: Kano  BeitragVerfasst am: 05.11.2006, 18:58 Uhr
Team Member
Team Member


Anmeldung: 03. Mai 2005
Beiträge: 1544
Wohnort: out there somewhere
I have an older hauppauge card, what I did was make a .xawtv file in my /home/piper and just opened xawtv without configuring it and it just worked, maybe this might work for you to. (change the channel listings to your channels, this is from western ny)


[global]
freqtab = us-cable

[defaults]
input = Television
norm = NTSC

[unknown (2)]
channel = 2

[unknown (3)]
channel = 3

[unknown (4)]
channel = 4

[unknown (5)]
channel = 5

[unknown (6)]
channel = 6

[unknown (7)]
channel = 7

[unknown (8)]
channel = 8

[unknown (9)]
channel = 9

[unknown (10)]
channel = 10

[unknown (11)]
channel = 11

[unknown (12)]
channel = 12

[unknown (13)]
channel = 13

[unknown (14)]
channel = 14

[unknown (15)]
channel = 15

[unknown (16)]
channel = 16

[unknown (17)]
channel = 17

[unknown (18)]
channel = 18

[unknown (19)]
channel = 19

[unknown (20)]
channel = 20

[unknown (21)]
channel = 21

[unknown (22)]
channel = 22

[unknown (23)]
channel = 23

[unknown (24)]
channel = 24

[unknown (25)]
channel = 25

[unknown (26)]
channel = 26

[unknown (27)]
channel = 27

[unknown (28)]
channel = 28

[unknown (29)]
channel = 29

[unknown (30)]
channel = 30

[unknown (31)]
channel = 31

[unknown (32)]
channel = 32

[unknown (33)]
channel = 33

[unknown (34)]
channel = 34

[unknown (35)]
channel = 35

[unknown (36)]
channel = 36

[unknown (37)]
channel = 37

[unknown (38)]
channel = 38

[unknown (39)]
channel = 39

[unknown (40)]
channel = 40

[unknown (41)]
channel = 41

[unknown (42)]
channel = 42

[unknown (43)]
channel = 43

[unknown (44)]
channel = 44

[unknown (45)]
channel = 45

[unknown (46)]
channel = 46

[unknown (47)]
channel = 47

[unknown (48)]
channel = 48

[unknown (49)]
channel = 49

[unknown (50)]
channel = 50

[unknown (51)]
channel = 51

[unknown (52)]
channel = 52

[unknown (53)]
channel = 53

[unknown (54)]
channel = 54

[unknown (55)]
channel = 55

[unknown (56)]
channel = 56

[unknown (57)]
channel = 57

[unknown (58)]
channel = 58

[unknown (59)]
channel = 59

[unknown (60)]
channel = 60

[unknown (61)]
channel = 61

[unknown (62)]
channel = 62

[unknown (68)]
channel = 68

[unknown (69)]
channel = 69

_________________
h2's d-u script
h2's rdiff-backup script
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
gs
Titel: RE: Re: Kano  BeitragVerfasst am: 06.11.2006, 06:46 Uhr



Anmeldung: 06. Jan 2005
Beiträge: 632

just tried Pipers tip, found .xawtv (as a hidden file) in another partition with Kanotix on it (having used the search function)
and it worked just as well as tvtime with my Hauppauge card......
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
loyl1
Titel: RE: Re: Kano  BeitragVerfasst am: 06.11.2006, 18:22 Uhr



Anmeldung: 21. Dez 2005
Beiträge: 18

dennister,

Run "dmesg" in a console window and post the IVTV section. I think your problems lie a few layers below the applications you are trying to use.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
loyl1
Titel: RE: Re: Kano  BeitragVerfasst am: 15.11.2006, 06:26 Uhr



Anmeldung: 21. Dez 2005
Beiträge: 18

dennister,

It would be nice if you would check your posts more often then I do. I feel your pain and I think I can help but you didn't stick around long enough for someone to really help you. I've wasted a lot of time checking back to see if you had responded - 9 to 10 times hoping to help you. All these times I am checking my posts hoping for the help I need on my own posts.

Show some persistence.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.