24.10.2014, 10:36 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
coady
Titel: Mount FAT32 shared partition with 'write' access  BeitragVerfasst am: 18.12.2006, 12:33 Uhr



Anmeldung: 19. Okt 2006
Beiträge: 41
Wohnort: Berlin
I have a simple but annoying problem. I want to automatically mount a shared data partition at boot-up in order to read/write data and to share email and web browser information. I have a separate partition formatted to FAT32 (vfat). I have created a mount point (/winshare) and added a line to '/etc/fstab'. For various reasons I would prefer to have an independent mount point rather than mounting it in '/home/user_name' (where I assume I would have read/write access by default). However, while the partition mounts, I can see and access the data, I cannot get write permission.

Here is the relevant information.

$ mount:
Code:
/dev/sda2 on /winshare type vfat (rw,uid=1000,gid=1000)

'/etc/fstab':
Code:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>     <options>             <dump>  <pass>
proc            /proc           proc       defaults              0       0
usbfs           /proc/bus/usb   usbfs      devmode=0666       0   0
sysfs           /sys            sysfs      defaults              0       0
tmpfs           /dev/shm        tmpfs      defaults              0       0
/dev/sda5       /               reiserfs   defaults              0       1
/dev/sda1       /media/sda1     ntfs      ro,umask=000,nls=utf8      0       0
/dev/sda2       /winshare   vfat      auto,rw,uid=1000,gid=1000 0       0
/dev/sda6       /home      ext3      defaults              0       0
/dev/sda7       none            swap      sw                    0       0
/dev/hdc        /media/cdrom0         udf,iso9660 user,noauto      0       0OC


I have tried mounting the partition using <options>:
"rw,auto,users"
and
"defaults"
as well as what you can see above
"auto,rw,uid=user_name,gid=group_name"

I have also tried to run '# chmod' on the mount point, for e.g., '# chmod ug+w /winshare' but while I can change all these options, I cannot change the write permission.

Can anyone advise me on this? Thanks.

coady
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: RE: Mount FAT32 shared partition with  BeitragVerfasst am: 18.12.2006, 12:43 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16275

Sample entry for UTF8 systems:

/dev/sda2 /media/sda2 vfat exec,umask=000,shortname=mixed,quiet,iocharset=utf8 0 0

remove ",iocharset=utf8" if no UTF8 is in

echo $LANG
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
coady
Titel:   BeitragVerfasst am: 18.12.2006, 14:35 Uhr



Anmeldung: 19. Okt 2006
Beiträge: 41
Wohnort: Berlin
I tried the following, but it doesn't work:
Code:
/dev/sda2       /winshare   vfat      rw,auto,umask=0000,uid=1000,gid=1000,iocharset=utf8   0       0
I am not sure why? I have tried other combinations too.
Is the problem the location of the mount point in the file system?
Note, utf8 is set in LANG.

coady
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
penguin.ch
Titel:   BeitragVerfasst am: 18.12.2006, 14:39 Uhr



Anmeldung: 11. Dez 2006
Beiträge: 31

Not sure if this is important, but the value for umask consists of 3 digits (not 4, as you posted).

_________________
There are two major products that came out of Berkeley: LSD and UNIX.
We don't believe this to be a coincidence. (Jeremy S. Anderson)
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
coady
Titel:   BeitragVerfasst am: 18.12.2006, 14:43 Uhr



Anmeldung: 19. Okt 2006
Beiträge: 41
Wohnort: Berlin
penguin.ch hat folgendes geschrieben::
Not sure if this is important, but the value for umask consists of 3 digits (not 4, as you posted).
Thanks, you are correct. It should be "umask=000" and not "umask=0000".
coady
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
penguin.ch
Titel:   BeitragVerfasst am: 18.12.2006, 14:57 Uhr



Anmeldung: 11. Dez 2006
Beiträge: 31

Just in case your problem remains unsolved: the entry referring to my "file share" looks like this:

Code:

/dev/sdf1 /data vfat rw,users,uid=1000,gid=1000,umask=022 0 0

Remark, although possibly silly: have you checked the UID / GID of the user in charge?

HTH
Birdy

_________________
There are two major products that came out of Berkeley: LSD and UNIX.
We don't believe this to be a coincidence. (Jeremy S. Anderson)
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 18.12.2006, 15:20 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16275

Are you too stupid to use the example I told you? You do NOT need uid/gid.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
coady
Titel:   BeitragVerfasst am: 18.12.2006, 20:13 Uhr



Anmeldung: 19. Okt 2006
Beiträge: 41
Wohnort: Berlin
Kano hat folgendes geschrieben::
Are you too stupid to use the example I told you? You do NOT need uid/gid.
No. I am not too stupid. I have just been trying to figure out why this won't work.

I have entered the following setting in '/etc/fstab':
Code:
/dev/sda2 /media/sda2 vfat exec,umask=000,shortname=mixed,quiet,iocharset=utf8 0 0

command "mount" looks like this:
Code:
/dev/sda2 on /media/sda2 type vfat (rw,umask=000,shortname=mixed,quiet,iocharset=utf8)

command "ls -l" looks like this:
Code:
drwxrwxrwx 6 root root 4096 1970-01-01 01:00 sda2
It should work, but I can't write to "/dev/sda2". The strange thing I noticed here is the date (i.e. "1970-01-01 01:00").

It is frustrating for me too...

coady
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
horo
Titel:   BeitragVerfasst am: 19.12.2006, 07:54 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 700
Wohnort: Berlin
Zitat:

It should work, but I can't write to "/dev/sda2". The strange thing I noticed here is the date (i.e. "1970-01-01 01:00").

Don't write to /dev/sda1 - use /media/sda1 instead!

Ciao Martin

_________________
omnia vincit pecunia
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
coady
Titel:   BeitragVerfasst am: 19.12.2006, 08:54 Uhr



Anmeldung: 19. Okt 2006
Beiträge: 41
Wohnort: Berlin
Thanks to everyone who helped here. I now have read/write access to the shared partition.
coady
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Richard
Titel:   BeitragVerfasst am: 19.12.2006, 15:27 Uhr



Anmeldung: 07. Nov 2005
Beiträge: 112
Wohnort: Venezuela
@coady:
You are a paragon of restraint.

Auf Wiedersehen.

_________________
kanotix-2006-01, 2.6.18.5-slh-up-1, IceWM, Krusader; P4, 2.8GHz, 512MB
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
coady
Titel:   BeitragVerfasst am: 19.12.2006, 18:37 Uhr



Anmeldung: 19. Okt 2006
Beiträge: 41
Wohnort: Berlin
Richard hat folgendes geschrieben::
You are a paragon of restraint
Richard,
There were a number of small problems that existed together.
- One was that I had a typo in the "umask" entry, 'umask=0000' whereas it should be 'umask=000'.
- The 'utf-8' flag is set in LANG, but I tried both ways, and it doesn't seem to be the problem. I can read/write with or without 'utf-8' in the 'fstab <options>'.
- It also looks like when I issued the "chmod" command on the mount point that, either I did not do it correctly, or I did not run it recursively, or some other oversight (I tried this many times, but perhaps should have been more systematic). There were a handful of folders down within the file structure that remained write protected. When I looked at the mount point and the main file/directory elements they all had read/write permission, but not some of the deeper directories. I found this by carefully looking through the layers of directories and running "ls -l". I am not certain but I think this may be related (or not) to setting special folder attributes in windows xp. It was only folders that had not standard icon attributes that did not also have write access. Again, I am not certain about the reasons, however. I hope this makes it clearer. Thanks again to everyone who helped out.

regards,
coady
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.