21.05.2018, 23:56 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
neppomuk
Titel: fast völlig begeistert  BeitragVerfasst am: 01.12.2007, 12:14 Uhr



Anmeldung: 01. Dez 2007
Beiträge: 6

Hi.

Bin neu im Forum. Nutze Unix/Linux seit fast 30 Jahren.

Zuerst: die neue Thorhammer ist fantastisch. Allein der Name....
Dank an Kano und das Team.

Teste auf altem Bock, 1300er, NV 5200, Intel Chips, Asus Board.
Out of the Box lief LiveCD, Installation, VDR (wenn auch mit USB Einschränkungen auf der alten Gurke), Beryl (der Wahnsinn, natürlich in xconf konfiguriert), Wine.
Wlan läuft nicht.
Mit der RC6 erkannte er den alten Prism2 nicht als Wlan-Device; den RT2500 erkannte er, aber keine Verbindung zum Router möglich.
Mit RC6B das gleiche.
Dazu eine Frage:
die alten ifcfg-wlan0 und so sind ja weg. Jetzt steht alles in Interfaces.
Aber wo erden die unterschiedlichen Konfigurationen der wlan-Devices gespeichert ?
So dass ich für verschiedene Karten/Sticks unterschiedliche Konfigurationen testen kann ?
Bin alter Terminal-Fan, und nutze mc und kedit/kwrite für Änderungen, um die netcardconfig und so zu vermeiden.
Seit frühen Versuchen mit Suse traue ich Konfig-Tools nist (YAST = Yalles Awird SuperTüberschrieben).
Wo kann ich nachlesen, wie das wlan jetzt strukturiert wird ?

Danke im Voraus -
neppo
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: fast völlig begeistert  BeitragVerfasst am: 01.12.2007, 12:17 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16613

Normalerweise wird alles per network-manager icon (rechte mausstaste drauf) konfiguriert.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
neppomuk
Titel: fast völlig begeistert  BeitragVerfasst am: 01.12.2007, 12:39 Uhr



Anmeldung: 01. Dez 2007
Beiträge: 6

Kano:
Nutze dhcp nicht... kann der NWMan denn inzwischen static ?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
merlin
Titel: fast völlig begeistert  BeitragVerfasst am: 01.12.2007, 12:58 Uhr



Anmeldung: 28. Feb 2005
Beiträge: 1112
Wohnort: Camelot
der kann kein static
deinstallier ihn mal apt-get --purge remove network-manager
setz mal die interfaces zurück

echo -e auto lo\\niface lo inet loopback > /etc/network/interfaces

und boote neu, dann mit netcardconfig neu konfigurieren
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: fast völlig begeistert  BeitragVerfasst am: 01.12.2007, 13:06 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16613

dhcp ist find ich viel besser wie statisch... aber wennst meinst es nicht zu brauchen musst halt mit einschränkungen leben.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
neppomuk
Titel:   BeitragVerfasst am: 01.12.2007, 13:28 Uhr



Anmeldung: 01. Dez 2007
Beiträge: 6

Kano:
Habe POP-, Mail-, Http-, FTP-Server (Linux) am Router. Feste IP wegen Firewall.
Hab's halt so gelernt...

Merlin:
Werde nochmal fummeln mit netcardconfig.

(Kleine Schrift und leises Grummeln:)
Wüßte aber doch gern wo jetzt was steht und wer was aufruft, wenn /log/messages mir sagt:
taking configuration 1 von 1 config...
So ne nette Mac-Zuordnung z.B. wäre vielleicht hilfreich.
Versuche ja nur, halbwegs mit den Entwicklungen mit zu kommen...
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
neppomuk
Titel:   BeitragVerfasst am: 01.12.2007, 14:57 Uhr



Anmeldung: 01. Dez 2007
Beiträge: 6

Da bin ich wieder. Also:
Nach remove network manager startet kde nicht mehr. Gnome geht noch, und wenn ich Gnome starte, Sitzung beende, und dann KDE starte, gehts. Reboot - nur KDE - geht nicht; Gnome erst und dann KDE geht (reproduzierbar). Merkwürdig.
WLAN: alles wird erkannt, Key und SSID und Access point sind in iwconfig, aber kein Ping Router. (Bin jetzt wieder mit eth0 drin).
Eins ist auffällig: beim reinstecken des WLANStick kommt folgende Fehlermeldung in messages:
Dec 1 15:05:34 kernel: [ 890.644000] usb 1-1: configuration #1 chosen from 1 choice
Dec 1 15:05:34 kernel: [ 891.252000] iwlwifi_rc80211_simple: Unknown symbol iwlwifi_ieee80211_rate_control_unregister
Dec 1 15:05:34 kernel: [ 891.252000] iwlwifi_rc80211_simple: Unknown symbol iwlwifi_sta_info_put
Dec 1 15:05:34 kernel: [ 891.252000] iwlwifi_rc80211_simple: Unknown symbol iwlwifi_sta_info_get
Dec 1 15:05:34 kernel: [ 891.252000] iwlwifi_rc80211_simple: Unknown symbol iwlwifi_ieee80211_rate_control_register
Dec 1 15:05:34 kernel: [ 891.420000] usbcore: registered new interface driver rt2500usb
Treiberproblem mit MadWiFi ?

Grüße
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 01.12.2007, 16:09 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16613

rt2500 ist doch kein madwifi.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
neppomuk
Titel:   BeitragVerfasst am: 04.12.2007, 19:17 Uhr



Anmeldung: 01. Dez 2007
Beiträge: 6

Bin wieder da.
Weiß jetzt mehr... kein MADWIFI, natürlich.
Der Stick funktioniert - iwlist scan stellt mein Netz dar.
Ich kann den Stick auch anpingen, aber ich komme nicht ins LAN.
Habe dann eine alte PCI Karte wlan in den Rechner gesteckt - da ist alles wunderbar (ADMTek chip). Funzt auf Anhieb.
Stecke ich den Stick dazu, wird rt2500 aktiviert, Ping funzt, Kismet stellt das Ding auch auf Monitor um - aber kein Lan.
route -n ist bei beiden gleich.
iwconfig ist bei beiden gleich (bis auf HWADDRESS, natürlich).
Habe dasselbe auf einer Fedora8 getestet (andere Kiste) - genau dasselbe.

Hat einer von Euch dazu eine Erklärung ?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 04.12.2007, 22:39 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16613

Der Treiber ist einfach nur mies.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
hotmifi
Titel:   BeitragVerfasst am: 05.12.2007, 04:52 Uhr



Anmeldung: 19. Jul 2005
Beiträge: 47

rt2500 gehört auf jede anständige blacklist. Ich arbeite auf vier, zeitweise fünf, verschiedenen Distros und auf keiner funzt das Ding. Es simuliert einen Treiber, ist aber keiner. Mit ndiswrapper läuft so ein Stick allerdings einwandfrei und stabil.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
neppomuk
Titel:   BeitragVerfasst am: 05.12.2007, 17:17 Uhr



Anmeldung: 01. Dez 2007
Beiträge: 6

Danke, Hitmifi.
Problem ist gelöst.
Habe den rt2570usb Treiber von uni Darmstadt installiert, da es ein dwl122 stick von d-link ist. Funktioniert als rausb0 - alles super.
Der rt2500 muss allerdings gelöscht werden (die .ko), sonst mischt sich da irgendwas...
Ndiswrapper wäre dann der nächste Schritt gewesen - unnötig.

Ich muss allerdings sagen, dass mir die Sache mit der Interfaces nicht so gut gefällt wie ifcfg-wlano usw.

Danke nochmal
neppo
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 05.12.2007, 17:29 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16613

Du brauchst auch keine interfaces wennst dhcp nimmst...
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.