28.07.2014, 21:45 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
Sadie
Titel: [solved]2010 KDE 3.5.10 64 live DVD install dexconf error  BeitragVerfasst am: 29.06.2010, 21:14 Uhr



Anmeldung: 29. Jun 2010
Beiträge: 7
Wohnort: USA
Hi all,

This is my first trial with Kanotix and it has been a bit difficult for me to install. ( I ordered the DVD from linuxcd dot org, as I use dial up.)

At menu start, if I select "English" the live disk starts up, but never starts init. It gives me an error, though I do not know exactly the wording, but this is a guess:

"dexconf error". Something about, "missing keyboard layout in xorg.conf" and the output says, "run dkpg-reconfigure xserver-xorg to fix this problem". It then boots into the KDE GUI desktop and I open command shell and enter "dpkg --reconfigure xserver-xorg, but it says there is no such command as "reconfigure" so I look in dpkg --help files and it says to use --configure. I do this as sudo and it states that xserver-xorg is already installed. So, that was a dead end.
I then looked in /etc/X11/ and the xorg.conf file is completely empty - 0mb. I change keyboard to US, and then use the Katonix installer to install. Everything goes well, and at restart, there is only verbose output and it finishes at command line to login. If I log in and type "startx" it gives me a ksplash error. So, no KDE GUI.
Sorry to give these errors from memory. If I knew where the start up text was stored, I would post it here so you could read the output. I didn't see anything in /var/logs, though I didn't look through each folder or file.

Anyway, I then try another install, and this time I choose Deutsch and I get no dexconf error, and the live DVD boots up into the KDE desktop just fine. Having a look in /etc/X11/, my xorg.conf file is completely filled in with information. I then change keyboard to US, and also go to country/region & language and make sure language is in English. I then install and it all goes well. So far, so good, but maybe someone else can confirm this error when choosing 64 English install.

And thank you for your time!
Sadie


Zuletzt bearbeitet von Sadie am 30.06.2010, 04:08 Uhr, insgesamt ein Mal bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: 2010 KDE 3.5.10 64 live DVD install - dexconf error  BeitragVerfasst am: 29.06.2010, 21:52 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16219

Yes, i saw that problem before, but could not reproduce it. Usally the hd install should get the same config of xserver-xorg, but in some cases it does not. How many hds do you have got installed? It can be fixed using

dpkg-reconfigure xserver-xorg

thats correct.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Sadie
Titel: RE: 2010 KDE 3.5.10 64 live DVD install - dexconf error  BeitragVerfasst am: 29.06.2010, 22:21 Uhr



Anmeldung: 29. Jun 2010
Beiträge: 7
Wohnort: USA
Hello Kano,

I am using the Live DVD now, and looking at /var/log/live.log it gives the output:
Code:
Generating locales (this might take a while)...
  en_US.UTF-8... done
Generation complete.
dexconf: error: cannot generate configuration file;
xserver-xorg/config/inputdevice/keyboard/layout not set.  Aborting. 
Reconfigure the X server with "dpkg-reconfigure xserver-xorg" to correct this
problem.
xserver-xorg postinst warning: error while preparing new Xorg X server
   configuration file in /etc/X11/xorg.conf.dpkg-new; not attempting to
   update existing configuration


I can reproduce problem each time I use the live disk and try to: "start Katonix 64 English" and end up with empty xorg.conf file.

I have two hard drives. The first (sda) has XP with an extended partition formated as ntfs. The second hard drive (sdb) is extended with three logical partitions. Third partition has a Linux distro formatted as ext4, and second partition is where I installed Katonix as ext4. Oh, there is a Linux-swap partition at the end of these three partitions. The first partition is unformatted and empty (at the moment).

I did try command:
dpkg-reconfigure xserver-xorg
but did so after I booted into live session. The dpkg error I got was something like, "no such command -reconfigure".
I'd like to try this again. Are you saying to
dpkg-reconfigure xserver-xorg
after install, (no GUI present) and before logging in?

Again, thank you for your time, as I know it is late in evening for those in Europe.
Sadie
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: RE: 2010 KDE 3.5.10 64 live DVD install - dexconf error  BeitragVerfasst am: 29.06.2010, 23:04 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16219

Hmm you are right. I only tested it with vbox in English, there the error does nothing. Basically it could be fixed when you add a cheat like

klayout=us

then there is no error. Basically it a problem of live-initramfs that there is no good default.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Sadie
Titel: RE: 2010 KDE 3.5.10 64 live DVD install - dexconf error  BeitragVerfasst am: 30.06.2010, 04:06 Uhr



Anmeldung: 29. Jun 2010
Beiträge: 7
Wohnort: USA
Thanks for testing it. The problem only arises when choosing the English install.

Well, I did as you instructed after re-installing again, as I wanted to see if the command, dpkg-reconfigure xserver-xorg would work, as whenI tried it earlier today, I was already in the KDE xserver GUI, so it didn't work. So, this time I installed, and after command line log-in, I "sudo dpkg-recconfigure xserver-xorg" which brought me to a simple screen to ask me questions about my keyboard. That was done, then I rebooted and I'm happy to say the xserver GUI is back up.
Kano, thanks again for your help! And I must say, what a nice crisp looking desktop it is. It has been many months since I've used KDE 3.5 and the fonts and icons are sharp looking, unlike my other distro that uses the latest KDE 4 version and nVidia driver.
A big thanks to those that created and work on Katonix!
Sadie
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Sadie
Titel: RE: 2010 KDE 3.5.10 64 live DVD install - dexconf error  BeitragVerfasst am: 01.07.2010, 15:28 Uhr



Anmeldung: 29. Jun 2010
Beiträge: 7
Wohnort: USA
Here's an easier way to do it. Maybe someone can add this to a wiki on those using the Live disc>Start Katonix 64 English and want to install it.

!. Using Bootable Live KATONIX 64 with KDE 3.5.10 desktop, select from menu:
Start KATONIX 64 English
2. Once in desktop, click on KDE Keyboard Tool (the flag icon in bottom panel) and "configure" selecting US and using arrow to place it first. Apply, OK.
3. Click
ctrl alt F1
which will bring you out of graphical user interferface and into bash command-line verbose mode.
4. Type:
sudo dpkg-reconfigure xserver-xorg
and click "enter".
This will bring you to simple package configuration page for xserver layout. Answer the questions using up and down keys and left right arrow keys to scroll, and read text and to select "OK" when finished with each question, "enter". It will finish up by taking you back to bash command-line.
5. Click
ctrl alt F7
will bring you back to graphical interface and you should now have a filled out /etc/X11/xorg.conf file.
6. You are now ready to click on
KATONIX Acritoxinstaller
Once installation is complete, restarting will now bring you to an expected graphical interface login.
Sadie
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
hardtime
Titel: Intel Video Problem  BeitragVerfasst am: 07.07.2010, 03:27 Uhr



Anmeldung: 07. Jul 2010
Beiträge: 7

My monitor reported 'unsupported video mode' when I tried to install.
my solution...
Use the 'klayout=us' as suggested by Kano.
Kanotix Live will come up, even though you see only the video error message.
You know that you're up when the kde start music plays.
Get to a console, alt-ctrl f1,
and install and run 'smxi':
cd /usr/local/bin
$ sudo wget -Nc smxi.org/smxi.zip
$ sudo unzip smxi.zip
$ sudo ./smxi
This will setup smxi
and the last section will setup intel graphics for you.
Then just select number 1, Start Desktop.
You'll get Kanotix, and you can install.
You'll have to repeat this the first time you boot Kanotix
after the install.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: Intel Video Problem  BeitragVerfasst am: 07.07.2010, 08:28 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16219

You will never need to use a 3rd party script! Basically the problem is that
Code:
echo xserver-xorg xserver-xorg/config/inputdevice/keyboard/layout string us|debconf-set-selections

is not set when klayout=us is NOT added. In that case
Code:
# get rid of old config files
rm -f /etc/X11/xorg.conf*
dpkg-reconfigure -phigh xserver-xorg

will not create a config file (it will not on squeeze btw). But it is wrong to assume that when
Code:
dpkg-reconfigure xserver-xorg

asks you question something would be wrong, thats not the case, thats the normal behaviour - only with -phigh it errors out. Do NOT use smxi!!!
Instead just start kdm later:
Code:
/etc/init.d/kdm restart


Zuletzt bearbeitet von Kano am 07.07.2010, 20:55 Uhr, insgesamt ein Mal bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
hardtime
Titel: RE: Intel Video Problem  BeitragVerfasst am: 07.07.2010, 20:19 Uhr



Anmeldung: 07. Jul 2010
Beiträge: 7

Thank you, Kano, for the quick reply.
I'll try what you suggest, and probably post my results.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
hardtime
Titel: RE: Intel Video Problem  BeitragVerfasst am: 08.07.2010, 01:48 Uhr



Anmeldung: 07. Jul 2010
Beiträge: 7

my reply...

I reinstalled Kanotix without smxi.

The main fault that remains is lack of support for intel video in the installer.
Some modifications were necessary.

added cheatcode 'klayout=us' to installer command line
went to a console with alt-ctrl f1 after the kde start music
downloaded and installed the package 'xserver-xorg-video-intel'
( during the initial startup, the display still showed it's 'mode not supported' message )
downloaded and installed the package 'nano' to edit xorg.conf
backed up xorg.conf and edited as follows
to Section "Device" added 'Driver "intel"'
to Section "Screen" added 'Device "Configured Video Device"'
ran '/etc/init.d/kdm restart'

I got the Kanotix desktop at the normal 1600x900 resolution and did a normal install.
The initial boot gave me the 'mode not supported' message
and I repeated the intel driver install and xorg.conf modification.

I continued to have 'mode not supported' monitor errors during shutdown
so
I modified /etc/default/grub as follows
set cheatcodes to just 'quiet', no 'vga=791', no second 'quiet'
commented out GRUB_TERMINAL=console
uncommented GRUB_GFXMODE and set it to '1024x768'
ran /usr/sbin/update-grub

I no longer have 'mode not supported' monitor errors.

...later
I checked the install disk and found that the
xserver-xorg-video-intel package is supposed to be on the disk
but I don't know how to get it used.
The /etc/init.d/kdm script is new to me, but helpful.
It is a bit much to expect someone to jump through the hoops that I did
to get your distro installed. The smxi script was useful. I never would have gotten
your distro installed without it.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
hardtime
Titel: Still trying.  BeitragVerfasst am: 08.07.2010, 07:35 Uhr



Anmeldung: 07. Jul 2010
Beiträge: 7

I've been working on this install business.
It keeps me busy.
I need a cheat code that will cause the 'intel' driver to be loaded before X is started.
Or maybe one that will cause X to come up at a resolution supported by the monitor.
The best I've been able to come up with so far requires the network to be up so that I can download an editor, nano.
So I use the cheat 'klayout=us' and sit through a 'nonsupported video mode' error.
( I'm trying an older 17 inch monitor, and I'm still getting an 'out of range' error.)
This is the latest procedure:
Wait for the kdm start music to play.
change directory to /usr/local/bin
( I can't remember the exact name of the force vesa shell. )
$ sudo force-vesa.sh
and I'll get an xorg.conf that only needs 'vesa' changed to 'intel'
( The xserver-xorg-video-intel package on the disk will be used.)
$ sudo apt-get update
$ sudo apt-get install nano
$ sudo nano /etc/X11/xorg.conf
Change "vesa" to "intel" in the Device section.
$ sudo /etc/init.d/kdm restart

And I'll get a desktop from which I can run the installer.
Better, but still too complicated.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: Still trying.  BeitragVerfasst am: 08.07.2010, 10:26 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16219

That's very curious, normally intel is found automatically when possible. But some systems only showed a picture when the monitor was connected via dvi. Is the vga card not in

/usr/share/xserver-xorg/pci/intel.ids

which you use? You see the number with

lspci -nn|grep VGA

btw you don't need nano, there is mcedit if you don't know vim.

sed -i s/vesa/intel/ /etc/X11/xorg.conf

would do the same, but i still get not why a forced intel driver is different than autodetection...

Did you compare

/var/log/Xorg.0.log
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
hardtime
Titel: Success at last.  BeitragVerfasst am: 08.07.2010, 22:43 Uhr



Anmeldung: 07. Jul 2010
Beiträge: 7

Using your
lspci -nn | grep VGA
I found the graphics card to be 80862E22.
The computer is a year old Gateway SX2800-01,
with Intel X4500 integrated graphics.
I booted the install disk, 32 bit English,
with cheat codes
klayout=us single
At the root prompt I used vim, as you suggested,
to add 80862E22 to the file
/usr/share/xserver-xorg/pci/intel.ids
Then just # init 5
and I got to the desktop, no "mode not supported" message.

btw I use visudo occastionally in Linux,
and long ago used vi with the Amiga Manx C compiler.
I stopped coding when I started with Linux.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
hardtime
Titel: Shutting down.  BeitragVerfasst am: 08.07.2010, 22:53 Uhr



Anmeldung: 07. Jul 2010
Beiträge: 7

Again I got the 'mode not supported' message during shut down.
But that can be fixed in /etc/default/grub as I posted in a previous message on this page.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.