25.11.2014, 02:15 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
stalin2000
Titel: Fieser Bug in Wicd  BeitragVerfasst am: 02.07.2010, 23:38 Uhr



Anmeldung: 04. Jan 2007
Beiträge: 1604
Wohnort: Hamburg
Hallo Ihr,

in Wicd scheint es einen kleinen aber fiesen bug zu geben:

WEP-Netwerke mit 10 Zeichen werden anscheinend nicht unterstützt. Dies hat dazu geführt, daß "Linux" gerade ziemlich doof aussah. Na ja, der Gastgeber selbst hat zum Glück auch ein Linux installiert und ist daher tolerant. Ist aber schon ein peinlicher bug finde ich...

Oder ist es gänzlich unüblich WEP mit 10 Zeichen Passwörtern zu wählen (abgesehen davon, daß wep unsicher ist)?

Viele Grüße Christopher

_________________
Es ist dem Untertanen untersagt, den Maßstab seiner beschränkten Einsicht an die Handlungen der Obrigkeit anzulegen - Kurfürst Friedrich Wilhelm von Brandenburg
www.projektidee.org | www.gesundheitstabelle.de | www.neoliberalyse.de
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
TheOne
Titel: Fieser Bug in Wicd  BeitragVerfasst am: 03.07.2010, 05:09 Uhr



Anmeldung: 15. Mar 2008
Beiträge: 610

Hallo stalin2000,

mal abgesehen davon, dass man WEP mit 64 Bit-Schlüssel auch gleich komplett offen betreiben kann, würde ich hier jedoch eher einen Benutzerfehler vermuten.
WEP mit 64 Bit-Schlüssellänge erlaubt als Passwort entweder 5 Zeichen im Ascii-Format oder 10 Zeichen hexadezimal. Ich vermute nun, dass im Wicd nicht darauf geachtet wurde, dass man das Passwort in hexadezimaler Schreibweise angeben wollte und stattdessen die Eingabe auf Ascii Schreibweise stand.

Gruß TheOne

PS: als unüblich würde ich das nicht bezeichnen, aber die meisten die überhaupt WEP benutzen, verwenden WEP mit 128 oder 256 Bit Key, sprich 13 oder 29 Ascii Zeichen

_________________
Lenovo ThinkPad X220 | Core i7-2640M 16GB | Hellfire 3.6
FSC Tablet T4220 | Core2 Duo T7250 2GHz 3GB | Intel GMA X3100 | Hellfire 3.6
Clevo M570U | Core2 T7200 2GHz 2GB | Geforce Go 7950gtx | Hellfire 3.2
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: Fieser Bug in Wicd  BeitragVerfasst am: 03.07.2010, 15:59 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16296

Sollte dein ein WLAN mit WEP nur verschlüsselt sein und jemand anders dieses für etwas sinnfreies Nutzen wirst Probleme haben dich da rauszureden... Wenn der Router kein WPA kann dann muss der halt getauscht werden - ist dann meist eh nur b Speed.


Zuletzt bearbeitet von Kano am 03.07.2010, 17:42 Uhr, insgesamt ein Mal bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
stalin2000
Titel: Fieser Bug in Wicd  BeitragVerfasst am: 03.07.2010, 17:04 Uhr



Anmeldung: 04. Jan 2007
Beiträge: 1604
Wohnort: Hamburg
Ha ha, nein, ich habe selbstverständlich wpa2 zu Hause.

Der Tip mit dem Hex-Modus war gut, so hat es jetzt funktioniert (obwohl ich gestern auch hex versucht hatte, da ging's aber nicht)

_________________
Es ist dem Untertanen untersagt, den Maßstab seiner beschränkten Einsicht an die Handlungen der Obrigkeit anzulegen - Kurfürst Friedrich Wilhelm von Brandenburg
www.projektidee.org | www.gesundheitstabelle.de | www.neoliberalyse.de
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
TheOne
Titel: Fieser Bug in Wicd  BeitragVerfasst am: 03.07.2010, 19:09 Uhr



Anmeldung: 15. Mar 2008
Beiträge: 610

so ein fieser Bug aber auch ^^ Winken

zu der Sache mit der Sicherheit, wie bereits erwähnt, WEP ist NICHT sicher und das wird mittlerweile auch von der Rechtssprechung so angesehen
Kano hat da vollkommen Recht, wenn du da Pech hast wirst du bzw. der Anschlussinhaber zur Verantwortung gezogen, falls über diesen Anschluss Unfug betrieben wird

TheOne

_________________
Lenovo ThinkPad X220 | Core i7-2640M 16GB | Hellfire 3.6
FSC Tablet T4220 | Core2 Duo T7250 2GHz 3GB | Intel GMA X3100 | Hellfire 3.6
Clevo M570U | Core2 T7200 2GHz 2GB | Geforce Go 7950gtx | Hellfire 3.2
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.