19.12.2014, 14:29 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
conta
Titel: system settings and so  BeitragVerfasst am: 17.05.2011, 16:34 Uhr



Anmeldung: 17. Mai 2011
Beiträge: 2

hi,

i can't use some options of system settings
eg when I try to change time i see: Unable to authenticate/execute the action: 4,
the same when i try to change time zone

thx, conta

[latest 64 kanotix]
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Tejas
Titel:   BeitragVerfasst am: 17.05.2011, 16:52 Uhr



Anmeldung: 09. Mai 2011
Beiträge: 74

Time Zone change was also rejected on Live System.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
eco2geek
Titel:   BeitragVerfasst am: 18.05.2011, 06:49 Uhr



Anmeldung: 02. Mai 2004
Beiträge: 471
Wohnort: Portland, OR, USA
Try using "dpkg-reconfigure tzdata" as root from the command line instead.

ETA: Or log in as root using "sux" and run "kcmshell4 clock".
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 18.05.2011, 11:45 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16309

You can also change UTC in /etc/default/rcS. After you configured your timezone + utc setting run

fix-time

in a console and it will get the time from the internet.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
conta
Titel:   BeitragVerfasst am: 18.05.2011, 12:23 Uhr



Anmeldung: 17. Mai 2011
Beiträge: 2

thanks guys, i know about those options, but that's not my point in here

what i mean is [in general] that people use KDE because they dont wanna use command line
and it's not about time only, i can't also edit KDM and so.

eg. Date settings say that I will be asked to authentificate, but i am not, instead i got error i wrote upper

solution should not be to use command line, but fix the trouble with authentification ;]
maybe it's KDE problem, i dont know
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 18.05.2011, 12:35 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16309

I would definitely avoid to use kde settings for time/date settings. Basically it only needs to write /etc/timezone, but it will not appear in the debconf database that way without dpkg-reconfigure.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Tejas
Titel: Live System  BeitragVerfasst am: 18.05.2011, 12:51 Uhr



Anmeldung: 09. Mai 2011
Beiträge: 74

Live System

eco2geek hat folgendes geschrieben::
Try using "dpkg-reconfigure tzdata" as root from the command line
OR
Zitat:
System Settings>Time Zone
Select zone; Apply
System Settings>Time
Confirm change
Close window
Discard changes to Module

Cmd line $date verification

Unfortunately Digital Display on bottom right still shows UTC
So, in 'K' menu: Search 'xclock' & Run it Winken
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: Live System  BeitragVerfasst am: 18.05.2011, 17:17 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16309

That does not change utc (bios time) to localtime. You need to change the /etc/default/rcS. Basically it is better to use utc with every os, for Win there are reg hacks, if you use os x on the same pc then you definitely have to store the time as utc. When you dont store the time as utc then the time is always changed as soon as you boot win (twice a year).
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
TheOne
Titel: Live System  BeitragVerfasst am: 18.05.2011, 21:04 Uhr



Anmeldung: 15. Mar 2008
Beiträge: 610

@conta: some settings in KDE's systemsettings can be changed by root users only, like KDM settings - if you want to change them use
Code:
kdesu systemsettings
in KDE 4.4.5 the button to become root from the GUI is not implemented (i think it is in 4.5+, iirc)

Regards, TheOne

_________________
Lenovo ThinkPad X220 | Core i7-2640M 16GB | Hellfire 3.6
FSC Tablet T4220 | Core2 Duo T7250 2GHz 3GB | Intel GMA X3100 | Hellfire 3.6
Clevo M570U | Core2 T7200 2GHz 2GB | Geforce Go 7950gtx | Hellfire 3.2
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Tejas
Titel: Re: Live System  BeitragVerfasst am: 19.05.2011, 14:08 Uhr



Anmeldung: 09. Mai 2011
Beiträge: 74

Doesn't work:Frage
Code:
kanotix@Kanotix:~$ kdesu systemsettings
bash: kdesu: command not found
root@Kanotix:/home/kanotix# kdesu systemsettings
bash: kdesu: command not found

Kano hat folgendes geschrieben::
That does not change utc (bios time) to localtime. You need to change the /etc/default/rcS.
I'm not too worried about bios time, it can stay as it is. I just wish to change the time shown on the display at the bottom bar, so as not to lose track of time by being misled by the display and losing 2 hours Weinen
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: Re: Live System  BeitragVerfasst am: 19.05.2011, 14:31 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16309

kdesu is not in the normal path, only when you use alt+f2. But whats wrong using the correct console tools?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Tejas
Titel: Re: Live System  BeitragVerfasst am: 20.05.2011, 01:08 Uhr



Anmeldung: 09. Mai 2011
Beiträge: 74

Kano hat folgendes geschrieben::
kdesu is not in the normal path, only when you use alt+f2. But whats wrong using the correct console tools?
Because none of them seem to be having any effect in changing the time display on the bottom tool bar panel.

Anyway the best workaround I've found so far is to use 'tzselect' to obtain the appropriate tz value for kernel parameter 'timezone' as a one-off grub edit in conjunction with 'persistent'. thus:
Code:
kernel          /hx/vmlinuz fromiso=/dev/sda5/hx/kanotix-2.6.38rc6.iso boot=live config utc=yes locales=us quiet gfx=on persistent [timezone=America/Los_Angeles]
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: Re: Live System  BeitragVerfasst am: 20.05.2011, 08:37 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16309

Better use utc=no in your example. The command i told you are for a real hd install and NOT for persistent mode which is configured by the extra options you can use.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.