21.08.2014, 05:23 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
retabell
Titel: UEFI  BeitragVerfasst am: 30.03.2014, 13:59 Uhr



Anmeldung: 04. Sep 2006
Beiträge: 140

Habe mal einen Artikel zu UEFI im Wiki angelegt.
http://kanotix.com/index.php?module=pnWikka&tag=UEFIornotUEFIEN

Vielleicht wird noch nen HowTo draus,
wer beitragen will nur zu ...

retabell
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
rolo48
Titel: UEFI  BeitragVerfasst am: 31.03.2014, 12:49 Uhr



Anmeldung: 31. Aug 2004
Beiträge: 1038
Wohnort: Schleswig-Holstein
Irgendwas kann da nicht stimmen. Ich hab das neueste Iso geladen und mit dd auf den Stick gespielt. Das bootet sogar auf meinem alten Desktop rechner im UEFI-Modus.
Ebenso verhält sich mit meinem Acer Travelmate Laptop. Egal, ob das Bios im Lagcy_mode oder Uefi-Mode steht, das Memtest Menu hab ich noch nie gesehn.
Merkwürdigerweise lässt sich ein Kanotix aus 2012 einwandfrei installieren. Wenn ich dagegen den laptop im Legacy- Mode starten lasse, dann DF 64 installiere, was anstandslos funktioniert, kommt nach dem reboot folgende Meldung:
Code:
error:file /boot/grub/i386-pc/normalmo.mod not found
Enetrering recue mode
grub rescue>

Das wars dann, mehr passiert nicht (schaut man nach, ist die Datei tatsächlich nicht vorhanden)
Starte ich im Uefi-Mode , installiere dann wiederum DF64, kommt nach reboot
Code:
No bootable Device, Hit any Key

Da kann ich hiten, soviel ich will, Meldung kommt dreimal und dann steht die Kiste.

Ich denk mir immer dabei, das es sowas nicht geben kann, das ein Kanotix nicht zu installieren ist.
Wenn wir das nicht gelöst bekommen, nehme ich auch die alte Version und mach d-u, aber das ist die Version mit dem Zevenos-Kde und da gibt es viele Probleme.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: UEFI  BeitragVerfasst am: 31.03.2014, 16:16 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16234

Das ist ein Überrest von einem alten GRUB, der Wikiartikel ist ja nicht vollständig, man MUSS eine FAT32 partition auf /boot/efi mounten, welche entweder PRIMÄR (bei mbr partitionen) oder eine beliebige gpt Partition ist. Ca. 100-300 mb würde ich dafür nehmen, im allgemeinen würde ich empfehlen die erste Partition dafür zu verwenden, ist aber nicht zwingend. Nur so kann grub an passender Stelle abgelegt werden.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
retabell
Titel: Re: UEFI  BeitragVerfasst am: 31.03.2014, 17:59 Uhr



Anmeldung: 04. Sep 2006
Beiträge: 140

rolo48 hat folgendes geschrieben::
, das Memtest Menu hab ich noch nie gesehn.

Dann hast das Iso im UEFI-Mode gebootet....
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
rolo48
Titel: Re: UEFI  BeitragVerfasst am: 01.04.2014, 00:09 Uhr



Anmeldung: 31. Aug 2004
Beiträge: 1038
Wohnort: Schleswig-Holstein
retabell hat folgendes geschrieben::
rolo48 hat folgendes geschrieben::
, das Memtest Menu hab ich noch nie gesehn.

Dann hast das Iso im UEFI-Mode gebootet....


Boote ich im UEFI-Mode sehe ich kein Memtest...richtig?
Boote ich im Legacy_Mode sehe ich ebenfalls kein Memtest! Da scheint mir was falsch zu sein?
Leider kann ich nicht mehr ausprobieren, was passiert, wenn noch das Orig. Win7 drauf wäre.
Probleme mit diesem Acer hat auch Semplice (debian Sid) und Neptune (debian Wheezy). Dort ist nach der Install ebenfalls Grub irgendwo, aber nicht da wo es sein sollte.

Das mit der FAT32 Part. hab ich ausprobiert. Also, eine 200mb Fat32 Primere Part. zusätzlich eingerichtet, im UEFI-Mode gebootet und installiert. Keinerlei Hinweis im Installer bei der Installation. Alles lief wie sonst und zum Schluß, "installiere Grub in MBR von /dev/sda"
Nach reboot: "no bootable Device, hit any key"

Entweder nehme ich jetzt ein altes Dragonfire , bring das mit vielen Problemen auf den neuesten Stand oder ich nehm ein Debian 7.4 Kde und mach ein Kanotix draus oder ich leg das Ding in die Ecke und warte auf die göttliche Eingebung....
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
retabell
Titel: Re: UEFI  BeitragVerfasst am: 01.04.2014, 04:29 Uhr



Anmeldung: 04. Sep 2006
Beiträge: 140

rolo48 hat folgendes geschrieben::


Boote ich im UEFI-Mode sehe ich kein Memtest...richtig?

Ja so ist es

Zitat:
Boote ich im Legacy_Mode sehe ich ebenfalls kein Memtest! Da scheint mir was falsch zu sein?

Ja, da hast im UEFI-Mode gebootet, eventuell musst im Setup auch den USB-Stick explizit auf legacy stellen.

Zitat:
Nach reboot: "no bootable Device, hit any key"

Ja das Phänomen habe ich auch mit einem älteren Board

Zitat:
Entweder nehme ich jetzt ein altes Dragonfire ,


Stell sicher das das Iso im Legacy-Mode gebootet wird, also mit memtest,
und boote die Install dann auch im Legacy-Mode.

So funktioniert das bei mir.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: Re: UEFI  BeitragVerfasst am: 01.04.2014, 06:22 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16234

sudo efibootmgr -v

Sagt dir, ob uefi benützt wird im live mode, der selbe Befehl nach hd install zeigt auch einen kanotix64 Eintrag an, wenn der mountpoint ohne Rechtschreibfehler korrekt war, /boot/efi ist alles in Kleinbuchstaben. Nebenbei kann man grub-install sehr leicht patchen, dass es trotz EFI Boot im mbr installiert, nur biste ja nie im chat wenn du installiert. Dein mini Problem hätte ich längst gelöst.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
rolo48
Titel: Re: UEFI  BeitragVerfasst am: 10.04.2014, 14:32 Uhr



Anmeldung: 31. Aug 2004
Beiträge: 1038
Wohnort: Schleswig-Holstein
Zur Info
Ich hab das Problem mit dem Laptop erstmal auf Eis gelegt, obwohl es augenscheinlich ein Kanotix Problem ist, denn alles Andere, was auf Debian aufbaut, ließ sich installieren. Z.Z. benötige ich den Laptop nicht.

Außerdem warte ich noch auf andere Meldungen, wo vielleicht ähnliche Probleme auftauchen
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: Re: UEFI  BeitragVerfasst am: 10.04.2014, 17:40 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16234

Der Installer ist etwas simpel und hat keinen speziellen EFI mode, aber er geht, wenn man ihn korrekt nutzt. Nur ganz früher wurde mal /boot/efi zu spät gemountet, das ist längst behoben.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Daddy-G
Titel: UEFI-Artikel  BeitragVerfasst am: 11.04.2014, 08:23 Uhr



Anmeldung: 01. Mar 2005
Beiträge: 1411

Nun die Initiative von retabell zu diesem Artikel ist auf jeden Fall zu begrüßen.
UEFI ist ja kein "Problemchen", das nur einzelne User mit exotischer Hardware betrifft, sondern direkt oder indirekt jeden, früher oder später.
Leider sind hier vielleicht 5 Leute, die was beitragen möchten und 5 Leute die es auch können und das sind nicht unbedingt die selben. Traurig
Dessenungeachtet hoffe ich, dass der Artikel fertig und zitierfähig wird. Smilie
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
rolo48
Titel: Re: UEFI  BeitragVerfasst am: 14.05.2014, 07:18 Uhr



Anmeldung: 31. Aug 2004
Beiträge: 1038
Wohnort: Schleswig-Holstein
rolo48 hat folgendes geschrieben::
Zur Info
Ich hab das Problem mit dem Laptop erstmal auf Eis gelegt, obwohl es augenscheinlich ein Kanotix Problem ist, denn alles Andere, was auf Debian aufbaut, ließ sich installieren. Z.Z. benötige ich den Laptop nicht.

Außerdem warte ich noch auf andere Meldungen, wo vielleicht ähnliche Probleme auftauchen


Kommt Zeit, kommt Rat. Problem gelöst mit der Installation von Spitfire LXDE auf dem besagten Laptop. War Dragonfire doch etwas störrisch und hat immer im UEFI Modis gestartet, gab es bei Spitfire keinerlei Probleme. So wie alle anderen Debians und Derivate bootet es im memtest Modus.

Spitfire läuft sehr schnell, bootet in 5-8 Sekunden. Probleme bisher keine.
Wine-unstable und Lo nachinstalliert.

Einzig wieder mal das Schriftbild bei hoher Auflösung ist unerträglich für die Augen. Die Ubuntuschrift ist viel freundlicher zu den Augen. Kann man das nicht als Standard machen?
Mehr zu Spitfire LXDE in einem anderen Beitrag
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: Re: UEFI  BeitragVerfasst am: 14.05.2014, 11:38 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16234

Eigentlich sollte der Installer neuerdings problemlos mit UEFI zurechtkommen, wenn denn eine passende Fat Partition existiert (ca. 100 MB, primär bei MBR, sonst beliebige GPT Partition).
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
jokobau
Titel: Re: UEFI  BeitragVerfasst am: 15.05.2014, 22:54 Uhr



Anmeldung: 08. Jul 2006
Beiträge: 937
Wohnort: Stuttgart
Hab da einen ASUS in Bearbeitung mit win8.
Bei SF und bei DF lässt sich grub ordentlich in efi installieren.
Jedoch kommt bei beiden im grub-Menü der win-Bootmanager nicht vor.
Bei SF ließ sich das mit einem "update-grub" beheben. Bei DF nicht.
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
Kano
Titel: Re: UEFI  BeitragVerfasst am: 16.05.2014, 00:06 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16234

Du kannst grub-efi installieren oder einfach das custom.cfg laden, siehe !efi - ich bevorzuge dies, aber stell auch sicher, dass du unter win mit cmd (admin) mal "powercfg -h off" eingegeben hast.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.